[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: PATA System Slowdown

On 6/14/05, John Baab <john.baab@gmail.com> wrote:
> > It has loaded the via82cxxx *after* the ide_generic module.  Hence the
> > ide_generic driver (that doesn't allow DMA to be turned on) is being used.
> >
> > In /etc/modules put "via82cxxx" above ide_generic (if it appears), and reboot.
> > If via82cxxx is the right module, DMA should be enabled.
> Worked like a charm, DMA is now turned on and system seems a lot more
> stable.  My CPU usage still jumps, but there is a clear difference.
> -Thanks for all the help, John

I've been having the same problem with the same board but modifying
the /etc/modules was one of the first things I tried, and it still
refuses to load the modules in the order given. dmesg still shows
"Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2" loading
immediately after the sata (sata_via), probing all the ide devices,
then doing some ACPI stuff before my via82cxxx driver comes along and
fails to load because none of the ide devices are still available.

The BIOS states both my drives (which would be hda and hdc) are
capable of udma mode 5 and udma mode 2, respectively, and
/proc/ide/via reflects that data as well.

The only theory I've been able to develop for the modules loading out
of order was having modutils installed, but a remove and dpkg --purge
more than satisfies me that that was not the culprit.

I'm running out of ideas and any suggestions would be appreciated. I
can provide any confs or dmesg output given a theory but there's too
much that's possibly relevant to just start pasting randomly.

Reply to: