[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: SATA No partitionable media were found



On Tue, Apr 26, 2005 at 04:23:49PM +0200, Susanne Wenz wrote:
> I've got a new machine with K8S-MX board and SATA Samsung SP1614C and tried to 
> install it with sarge-amd64-netinst.iso, sarge-i386-1.iso and 
> sid-amd64-monolitic.iso, but all images stopped because "No partitionable 
> media were found".
> 
> I see that there is a package sata-modules-2.4.27-2-386-di. Does a CD-Image 
> exist which contains that package? Or does anybody know a different way to 
> get debian running on this machine?
> 
> I saw some similar problems but I couldn't find a solution oder didn't 
> understand it.

It is probably not possible to run that chipset with sata using 2.4
kernels at all.  You may even need a very recent 2.6 kernel to get
support.  Many people have had problems with sata module
loading/detection with 2.6.8 while 2.6.10/2.6.11 are doing much better.

You could try 'modprobe sata_sis' from console 2 during the install to
see if that module exists and if so if it detects anything.  Do it from
a 2.6 install (linux26 at boot: prompt on sarge i386 installs, just
normal on amd64 install since it only uses 2.6 kernels).

I have only tried nvidia, via and sil3112 sata controllers myself, and
so far no problems.  The via (A8V-Deluxe) detected perfectly with the
debian-pure64 sarge net install cd from a few weeks ago.

Len Sorensen



Reply to: