[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: quake3

Hi - I had this same problem with Enemy Territory, and had to google for
quite a bit before I found something that worked for me.

Some articles referenced loading my sound modules with the option
"mmap_valid=1".  This didn't change anything for me, but allegedly has
worked for others.  Here's an example of what to add to

   alias snd-card-0 snd-via82xx
   options snd-via82xx mmap_valid=1

Another article recommended this, which did do the trick:

  echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

Or if you use systune, add this line to /etc/systune.conf:

  /proc/asound/card0/pcm0p/oss:et.x86 0 0 direct

In both cases, you'll need to change the "et.x86" to the name of the
executable that runs quake3.

If I can locate them, I'll follow up for the post and provide references
for the original sources for this info.

FWIW, ET sound worked for me without these changes for a while, and then
went away.  I believe it was due to updating ALSA packages.  (It's tough
to say when you track unstable on a daily basis.)  Also FWIW, I have to
disable the GL extensions when I run ET in 64-bit or else the textures
flicker between solid black and the normal texture.  The amazing thing is
that the AMD64 is just about fast enough that the game remains playable,
even doing all of the rendering in software...


On Thu, February 10, 2005 14:22, Philippe said:
> hello
> i'm just installing quake3 on sid pure64.
> i think quake3 was not able to find libGL in /emul/ so i copy it in
> quake3 dir
> it's work but now I have no sound
> is there a solution pour this problem ?
> ------- sound initialization -------
> Could not mmap dma buffer PROT_WRITE|PROT_READ
> trying mmap PROT_WRITE (with associated better compatibility / less
> performance code)
> /dev/dsp: Input/output error
> Could not mmap /dev/dsp

Reply to: