[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: How to get SATA detected via netinstall

lsorense@csclub.uwaterloo.ca (Lennart Sorensen) writes:

> On Thu, Feb 03, 2005 at 06:01:14PM +0100, Helge Kreutzmann wrote:
>> Hello,
>> (please CC: me on replies, thanks)
>> I downloaded
>> http://debian-amd64.alioth.debian.org/debian-installer/2005-02-01/netboot/mini.iso
>> and booted the installer with "expert". I was able to set up the
>> network and get the full list of d-i. However, my SATA disk is not
>> detected at all, and I get a screen telling me (roughly translated
>> back into english):
>> Some modules could not be loaded
>> For a few pices of your hardware no linux-kernel modules are
>> available. If you continue with the installation it could be, that
>> theses modules are available later.
>> The missing modules and the devices, which need theses, are: sata_nv
>> (NVIDIA Corporation nForce3 SATA2), usb-storage (USB storage),
>> ide-core (Linux IDE supoport), ide-mod (Linux IDE driver),
>> ide-probe-mod (Linux IDE probe driver), ide-detect (Linux IDE
>> detection), ide-generic (Linux IDE support), ide-floppy (Linux IDE
>> floppy), ide-disk (Linux ATA DISK), ide-cd (Linuix ATAPI CD-ROM),
>> isofs (Linux ISO 9660 filesystem), sr_mod (SCSI CDROM)
>> I tried two different mirrors, and both times got the same result. I
>> could ignore this, but as said above, later on no hard disk is
>> detected (expected from the module list).
>> On the IDE primary master there is the DVD-burner which I booted from,
>> on the third master the SATA disk (which is seen by the BIOS).
>> The board is a MSI K8N NEO2 (NForce 3) and the SATA disk is blank.
>> Is this board supported by d-i or where do I get the IDE-modules?
> If this is using 2.6.8 kernel (not sure the installer has moved to
> 2.6.10 yet) there are known problems loading some sata drivers.  Check
> the mailing list archies for the last month or so and you should find
> some hints on it.  I can't remember the solution off hand.
> Len Sorensen

Also if it still is 2.6.8 then it won't find the module udebs since
the archive has 2.6.10 already.

Try the monolithic iso to avoid a version skew.


Reply to: