[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: netinst using gcc-3.4 packages: no valid Release file?

On 04-Aug-12 08:32, Harald Dunkel wrote:
> Several other packages could not be installed, but libstdc++6
> was never tried.
> Why were gcc-3.3-base and libstdc++5 selected instead of
> gcc-3.4 and libstdc++6?

This is because the installer uses the debootstrap package from
the gcc-3.3 archive which installs gcc-3.3-base and libstdc++5 and
not gcc-3.4-base and libstdc++6. The gcc-3.4 archive has a patched
debootstrap which installs gcc-3.4-base and libstdc++6.

Maybe the debootstrap in the gcc-3.3 archive could be patched to
additionally install gcc-3.4-base and libstdc++6 on amd64? This would 
not do any harm and it would make it possible to use a single installer 
for both the gcc-3.3 and the gcc-3.4 archive. Otherwise I would have to
make a separate installer for the gcc-3.4 archive.

Andreas Jochens

Reply to: