[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

still not able to boot my alpha under 2.6.x

I have verified once again that all the devices, including the scsi
adapter, are included in the kernel proper.  I have set up the alphas
from day one to not use modules as they are servers.  The system boots
fine under the 2.4.x and earlier kernels.  The error message at the end
of the boot process for the 2.6.x kernel is the typical "cannot find the
console and try to use the init=console=ttyS0" to force the console to

I have double-checked and reset all the tty* and console devices as they
exist under /dev/.  I have also tried several variations of boot options
including root=/dev/sda2, root=0x802, rootfstype=reiserfs,
init=console=ttyS0, etc.  All end with the same problem.

Some questions that might be part of the problem:

1) Does the aboot delivered with Debian/Sarge (stable) work with the
2.6.x kernels ?  The version is 0.9b-3.

2) This same version of aboot obviously supports reiserfs under 2.4.x.
Is the same true for 2.6.x ?

3) Does the naming/numbering of the scsi partitions change under 2.6.x
as compared to 2.4.x on the alpha ?  I have three scsi drives sda, sdb,
and sdc.  The root filesystem is stored on sda2 using reiserfs.  sda1
contains the kernel file that aboot finds to boot.

The kernel files are stored on a small partition under ext2 and it finds
the kernel, boots it, and further finds all the partitions on the hard
drive.  There is something screwy either setting up the root partition
or in finding the console.  From the messages to the console, it appears
that the parameters passed to the kernel are being interpreted

Any help appreciated.

James D. Freels, Ph.D.
Oak Ridge National Laboratory

Reply to: