[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: still not able to boot my alpha under 2.6.x

On Fri, Feb 24, 2006 at 03:11:49PM -0500, Freels, James D. wrote:
> I have verified once again that all the devices, including the scsi
> adapter, are included in the kernel proper.  I have set up the alphas
> from day one to not use modules as they are servers.  The system boots
> fine under the 2.4.x and earlier kernels.  The error message at the end
> of the boot process for the 2.6.x kernel is the typical "cannot find the
> console and try to use the init=console=ttyS0" to force the console to
> be.

Well, an error about not being able to find the console could be due to
failure to mount the root filesystem.  Are there any errors above that?

> I have double-checked and reset all the tty* and console devices as they
> exist under /dev/.  I have also tried several variations of boot options
> including root=/dev/sda2, root=0x802, rootfstype=reiserfs,
> init=console=ttyS0, etc.  All end with the same problem.

> Some questions that might be part of the problem:

> 1) Does the aboot delivered with Debian/Sarge (stable) work with the
> 2.6.x kernels ?  The version is 0.9b-3.

Yes, it does.

> 2) This same version of aboot obviously supports reiserfs under 2.4.x.
> Is the same true for 2.6.x ?

I don't believe aboot supports reiserfs at all.  It shouldn't need to; the
only filesystem aboot needs to access is the one holding the kernel and
initrd (if applicable), which is typically a small ext2 partition mounted on
/boot.  Once aboot loads the kernel, accessing filesystems is the kernel's

> 3) Does the naming/numbering of the scsi partitions change under 2.6.x
> as compared to 2.4.x on the alpha ?  I have three scsi drives sda, sdb,
> and sdc.  The root filesystem is stored on sda2 using reiserfs.  sda1
> contains the kernel file that aboot finds to boot.

Numbering of partitions certainly shouldn't have changed, but ordering of
SCSI devices *may* change if they're connected to multiple SCSI controllers
and the load order of the drivers happens to change.  If all your devices
are connected to a single controller, however, the devices will be in bus
order as always.

If you have multiple controllers, you can always try using /dev/sdb2 and
/dev/sdc2, to see if that gets it booting...

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Attachment: signature.asc
Description: Digital signature

Reply to: