[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mkinitrd/modprobe doesn't find sym53c8xx_2 (was Re: Built 2.6.8 kernel without ext3 bug and working qlogic driver)

Uwe Schindler wrote:
Did you use the default kernel-config file (you can find it in boot/config-2.6.8-xxxxx after installing a 2.6.8 image)? If not, just
You gave me the idea to try it first with a precompiled default kernel.
I took the stock binary kernel-image-2.6.8-1-smp
(kernel-image-2.6.8-1-smp_2.6.8-6_alpha.deb). As I was installing, the
following error occured:
Setting up kernel-image-2.6.8-1-smp (2.6.8-6) ...
/usr/sbin/mkinitrd: add_modules_dep_2_5: modprobe failed
FATAL: Module sym53c8xx_2 not found.

So I checked:
# find /lib/modules -name sym53c8xx*
...or is this the wrong place to look?

Then I changed /etc/mkinitrd/mkinitrd.conf to:
# MODULES=dep          <- old setting
MODULES=most           <- new setting
...and commented out sym53c8xx_2 in /etc/mkinitrd/modules and retried
with the same error.

I reread your post and tried:
* Before install: open /usr/sbin/mkinitrd in text editor and replace
the module in the line containing "qlogicisp" by "qla1280".
So I changed Line 588 to:
   s/^isp1020$/qla1280/; t
and retried with the same error as the result.

I set up a almost identical machine with the sarge rc2 installer to a 2.4.27 kernel. When I want to install 2.6.8-1-smp-6, I see the same error.

Since my boot drive is unchangeably on a ncr53c810 controller, I can't boot. What am I doing wrong?

Thanks for any help!

Regards, Adrian.

Reply to: