[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strange SCSI controller

Hash: SHA1

On June 12, 2004 05:39 pm, Steve Langasek wrote:
> Please test the kernel images that were posted to this list.  You are
> almost certainly being affected by the bug in cia_core.c.

I haven't tried any of the posted kernel images.  I did, however, (only) 
unapply the cia_core.c patch to kernel-source-2.6.6 and recompile with the 
configuration file that comes with kernel-image-2.6.6-1-generic.  The QLogic 
driver worked fine.

I'm certainly all for getting the cia_core.c patch revoked!  There was some 
discusion on what it was for.  The patch file from kernel-patch-debian-2.6.6 
seems claim it was suppose to:

+* Setup two 1G mappings if cia_rev == 1 in arch/alpha/kernel/core_cia.c.

Now if we can get whatever patch is stopping my CMD IDE controller from 
working revoked as well, and my ALSA patch for the ES18xx applied, I'll be 
able to start using Debian kernels again (that would be a good thing)!

- -T

PS:  Some asked what the controllers on my PWS500au were:

00:01:09.0 SCSI storage controller: QLogic Corp. ISP1020 Fast-wide SCSI (rev 
0000000:00:04.0 IDE interface: Silicon Image, Inc. (formerly CMD Technology 
Inc) PCI0646 (rev 01)

- -- 
 Tyson Whitehead  (-twhitehe@uwo.ca -- WSC-)
 Computer Engineer                        Dept. of Applied Mathematics,
 Graduate Student- Applied Mathematics    University of Western Ontario,
 GnuPG Key ID# 0x8A2AB5D8                 London, Ontario, Canada
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: