[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Strange SCSI controller


I've a PWS 433 which worked very well with linux kernels from the
woody-bootfloppies and several selfcompiled ones (version 2.4.X and 2.6.X)
and I never encounterd any problems.

Then I put a LSI-Controller (2 channels, UW, HVD) into it to test some
external Sun Storage. And from this moment on the kernel driver for the
SCSI controller (QLogic ISP 1020), which is connected to the internal
drives, crashed the kernel on boot. I removed the LSI card, but the kernel
crashed :-(

For testing purposes I installed freebsd, and wow, the QLogic controller
worked. I've installed woody with kernel 2.2.20 and it worked. Boot was ok
and the machine was stable.

Then I tried several new kernels (self compiled, debian kernels, 2.4.25 and
2.6.5), but they all crashed on boot. 

I've just tried it with Steves latest version of the d-i, but on this
version the d-i hangs when autodetecting the hardware ("Loading module
'qlogicisp' for 'Q Logic ISP1020 Fast-wide SCSI'...").

Has anyone already encountered this problem?


Joerg Hoh

Reply to: