[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tuxracer is super slow



On Thu, May 29, 2003 at 02:39:18PM +0200, Jaap Hogenberg wrote:
> On Wednesday 28 May 2003 03:05, Tom Vier wrote:
> > i have a dual 833 up2000+ and a pci radeon 7500. glxgears gets 192fps.
> > tuxracer is unplayably slow. it takes several seconds to respond to a key,
> > and it's about .5fps.
> >
> > if anyone else who has it working or not working could post their hw
> > config, i'd appreciate it. maybe i can take down what the problem is.
> >
> It seems you do not have 3D hardware accelaration working, and fall back
> on software 3D rendering. 
> I know there has been a problem to get the ATI supplied code into the Xfree86
> code tree, and there were plans to fork the xfree86 because of that.
> I'm not sure what the status is right now , but I do think you need to
> get source code with the right ATI stuff in it and compile your own.

I have a PCI Radeon 7500 running fine with 3D acceleration running.
You need to upgrade your X though and compile the appropriate DRM/DRI
modules (sorry, grep the archives which is the one from the kernel). I
can play tuxracer nicly on my single CPU, 20164 500 Mhz alpha.

So you either get one of the 4.2.1 test builds (the earlier ones
compile on woody) or Michael Dänzers DRI-packages which now work on
alpha as well. The latter are probably easier to install.

Greetings

          Helge
-- 
Helge Kreutzmann, Dipl.-Phys.               Helge.Kreutzmann@itp.uni-hannover.de
  gpg signed mail preferred    gpg-key: finger kreutzm@rigel.itp.uni-hannover.de
    64bit GNU powered                  http://www.itp.uni-hannover.de/~kreutzm
       Help keep free software "libre": http://www.freepatents.org/

Attachment: pgpm09oZ8wrsC.pgp
Description: PGP signature


Reply to: