[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Prob getting X going with Matrox card and Woody and XFree 4

Hi all,

I have installed Debian 3.0 onto an LX164 onto a new hard disk and can't
get X going. It runs
fine with Debian 2.2 and XFree 3.3 on the old disk.

Under Debian 2.2 /XFree 3.3 here is the /var/log/gdm/:0.log which shows
that I am using the svga driver and its runing at 1024x768
Sony Multiscan 200GS can do 1280x1024, Graphics card: Matrox Millenium
G200 SD 8Meg

(--) SVGA: PCI: Matrox MGA G200 PCI rev 1, Memory @ 0x09000000,
(--) SVGA: Linear framebuffer at 0x9000000
(--) SVGA: MMIO registers at 0xA000000
(--) SVGA: Video BIOS info block at 0x000c7b20
(--) SVGA: Found and verified enhanced Video BIOS info block
(--) SVGA: detected an SDRAM card
(--) SVGA: chipset:  mgag200
(**) SVGA: videoram: 8192k
(**) SVGA: Option "dac_8_bit"
(**) SVGA: Using 32 bpp, Depth 24, Color weight: 888
(--) SVGA: Maximum allowed dot-clock: 250.000 MHz
(**) SVGA: Mode "1024x768": mode clock =  85.000
(--) SVGA: Virtual resolution set to 1024x768
(--) SVGA: Using hardware cursor
(--) SVGA: PLL reference freq: 27.050 MHz
(--) SVGA: Read OPTION 0x40079121
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)

With Woody though I cant get X to run except ina  very low res mode. 
I have run apt-get upgrade and have the latest SATBLE version of XFree
under Debian 3.0. My kernel is the stock one from stable, Kernel: 2.2.20

running "X -configure"
        creates a /root/XF86Config.new file. Copies to /etc/X11 as
        XF86Config-4 and X comes up in a low res mode with 8 bit depth. 
        Its a very basic XF86Config file with no mode lines or H or V 
        freq rates for my monitor.

"dpkg-reconfigure xserver-xfree86" I entered:
        driver; mga
        memory; 8192
        framebuffer; yes
        mouse port; /dev/psaux  mouse; PS/2
        Monitor: HS 30-85  VS 50-120
        res; 1280x1024, 1024x786         
        depth; 24 

        it wrote an /etc/X11/XF86Config-4 file but startx shows the
        "couldn't open module mga_hal
        screens found but none have a usable configuration.
        Fatal server error: no screens found."

I tried "xf86config" and selected 
        card number 289 from database which is the Matrox G200SD
        chipset selected by this was mgag200 which is correct
        and driver: mga
        it wrote an /etc/X11/XF86Config file but I gather this is for
XFree 3.3 or < 4.0 anyways.

I also tried using an vga driver using dpkg-reconfigure but I get error
it cant do 24 bit color and I still get error about no screens found. 
(well I have tried lots of things but no luck)

Looking on google I get lots of hits about such a problem (i have a
dozen emails about it from archives) 
but none end in a resolution of the problem or a cure. Here is a typical

> Andreas Reschke said:
> > my system (IBM 43p/140 with Matrox Millenium II, Debian Woody 3.0 ) runs
> > very well. Now I want to configure the X-Server. The XF86Config-4 I've
> > created with 'dpkg-reconfigure xserver-xfree86'. But when I go to init 2
> > the system still stands hard. Only the Powerbutton works. There isn't a
> > /var/log/XFree86.0.log file, I can only see the first part with 'tail -f
> > XFree86.0.log' .
> > Can you send a working config file?
> Okay, I've re-installed Debian on my machine to look at this.  Using
> XFree86 4.1.0 from Woody I get the same behaviour as you - a hard lock.
> I'm now install 4.2.1 from testing to seem if it helps.  Also, I have
> a kernel framebuffer patch from Ani Joshi which he thinks might help.
> I'll keep you posted.
> Leigh.

So if anyone knows how I can get X running again that would be good. 
Was there a resolution of this problem? 
Should I use the mga driver or the svga driver? 

Michael Lake
Active caver, Linux enthusiast and interested in anything technical.

Reply to: