[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Milo fails on SX with 18Gb disk

On Fri, Mar 01, 2002 at 11:57:35AM +0100, jaap.hogenberg@nl.abnamro.com wrote:
> I'm running an PC164SX , using milo to boot my kernel,
> which was working fine when I used a 4.5 Gb scsi harddisk.
> Now I have put in a 18 Gb scsi disk and milo fails to load the kernel
> from that disk , or read the filesystems on it.
> It gives errors indicating it does not recognize the (ext2) filesystem.
> (BTW I can load a milo off a FAT filesystem on the 18 Gb disk)
> When I boot the kernel from the 4.5 Gb disk , but use the 18 Gb disk
> for / , it's all fine.  All filesystems check are OK.  So once the
> kernel is running it has no problem with the 18 Gb disk at all.
> I've tried the newer milo's for my system , all have the same behavior.
> I use ARC BIOS. The   scsi-controller is an AHA2940UW but that should not
> be a problem since the 4.5 Gb disk boots off it fine.
> Does anyone know off anything to try before I start converting to srm/aboot
> ? (Which I'm not to happy about, as it involves flashing , repartioning
> disks....)

You didn't say, but the ext2 partition on the 18GB disk that you are
failing to boot from, is it *really* large, or is it a *long* way from
the beginning of the disk?

If so, this may be a problem similar to the old "aboot" one, which was
solved by defining a small )<2GB) ext2 partition fairly close to the
start of the disk (within 2GB, IIRC), and then booting out of that.

Good luck.


Jay A Estabrook                            Alpha Engineering - LINUX Project
Compaq Computer Corp. - MRO1-2/K15         (508) 467-2080
200 Forest Street, Marlboro MA 01752       Jay.Estabrook@compaq.com

Reply to: