[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Java SDK or JRE for Alpha


> Does anyone have any comments on using the beta 
> Compaq Java SDK under Debian Linux for the Alpha? 
> (I am assume that it is in RPM format and will need to 
> be converted using alien.) 

Works fine, at least the JRE part. I haven't tried compiling
anything with it.

Yes, you have to use alien, but that's no problem.
At least not with the packages in question.

There are some tricks involved to get libcpml to work. Basically,
I followed an explanation from Thomas Weyergraf on how to get
CCC to work on Debian/Alpha, which was my primary goal at the
time. The recipe is the same for the JDK tough. I'll give you his whole
post here, pick what you need.

In addition, I installed OpenMotif from MetroLink. There is a link
to it (IIRC) from Compaq's page with install instructions for the Beta.
Or you could fiddle around MetroLink's pages and see if you find it.
It says it will work with Lesstif too, so you might get away with simply
Installing Lesstif from its Debian package.


the following doc should get the compaq C compiler going, although
it's definitely NOT the Good Debian (TM) way, since the Compaq tools
are not integrated in the debian package management. However, until
the proper debian installers are in place, this should get you going.
Just in case, you are of the impatient type ;-) Note, that the CPML
install is for EV6 arch only, since this is the only debian-alpha system
i run. One day, i'll put debian on the rest of my alphas as well, and then
the EV4/EV5 procedures will be included. However, aside from the CPML
package name and the file-sizes, the procedure should be the same.
A success/failure report would be nice, though....

------------->8 here we go 8<-------------------------

Here is a procedure, how to setup the Compaq C Compiler in Debian. 
The files installed are the ( currently ) latest Compaq versions, which are


Here is a step-by-step list of the files/packages/libs/progs, which
are needed by the Compaq Toolchain. They are presented in the order
in which the compaq-packages will be installed:

       ld-linux.so.2 is needed by libots-2.2.7-2
       libc.so.6.1 is needed by libots-2.2.7-2

       /bin/sh   is needed by cpml_ev6-5.1.0-2
       man is needed by ccc-
       /bin/sh   is needed by ccc-

And of course the Debian RPM packages:
       librpm1 3.0.3-1
       rpm     3.0.3-1
as well as the gcc compiler:
       gcc     2.95.2-13

Make sure, you have the packages installed. I typically do like this:

dpkg -l | grep gcc

and the like. the sh(1) should be on your system as well as  libc.so.6.1 and
ld-linux.so.2 anyway. It's safe, to assume they are there.

Now, follow the steps given next.

1. Install libots-2.2.7-2.alpha.rpm
   rpm -i --nodeps ./libots-2.2.7-2.alpha.rpm

2. Install the proper ( EV5 or EV6 ) version of the cpml-rpm.
   I'll use cpml for EV6, which is cpml_ev6-5.1.0-2.alpha.rpm

   rpm -i --nodeps ./cpml_ev6-5.1.0-2.alpha.rpm

   Now run the following commands manually:

   cd /usr/lib/compaq/cpml-5.1.0
   rm -f /usr/lib/compaq/cpml-5.1.0/libcpml_ev6.so

   Note, the following is *one* commandline:

   ld -shared -o libcpml_ev6.so -soname libcpml.so -whole-archive \
libcpml_ev6.a -no-whole-archive -lots
   And now the last two

   strip libcpml_ev6.so

3. This was the easy part. After that, you should have the following files
   and links ( note: sizes *may* vary, but should not. Just make sure, it's 
   there ;-)

   /usr/lib/libots.a -> compaq/libots-2.2.7/libots.a
   /usr/lib/libots.so -> compaq/libots-2.2.7/libots.so
   /usr/lib/compaq/libots-2.2.7/README     1437 bytes
   /usr/lib/compaq/libots-2.2.7/libots.a   194776 bytes
   /usr/lib/compaq/libots-2.2.7/libots.so  127004 bytes

   /usr/doc/cpml-5.1.0/README              9142 bytes
   /usr/doc/cpml-5.1.0/Release_Notes-5.1.0 3327 bytes
   /usr/include/cpml.h -> ../lib/compaq/cpml-5.1.0/cpml.h
   /usr/lib/compaq/cpml-5.1.0/cpml.h          5000 bytes
   /usr/lib/compaq/cpml-5.1.0/libcpml_ev6.a   1298239 bytes
   /usr/lib/compaq/cpml-5.1.0/libcpml_ev6.so  574960  bytes
   /usr/lib/libcpml.a -> ./compaq/cpml-5.1.0/libcpml_ev6.a
   /usr/lib/libcpml.so -> ./compaq/cpml-5.1.0/libcpml_ev6.so

4. Now Install the ccc compiler package:

   rpm -i --nodeps ccc-

   The install process should emit the following message:
   Using /usr/lib/gcc-lib/alpha-linux/2.95.2 (3).

5. Now you should be setup correctly. You can check, by using
   ccc -v

   that would emit the following message:

   comp.config contains:  -SD/usr/lib/compaq/ccc- -SD/usr/local/include -SD/usr/lib/gcc-lib/alpha-linux/2.95.2/include -SD/usr/include | -SysIncDir /usr/lib/compaq/ccc-   -SysIncDir /usr/local/include -SysIncDir /usr/lib/gcc-lib/alpha-linux/2.95.2/include -SysIncDir /usr/include -L/usr/lib/compaq/ccc-   -L/usr/lib/gcc-lib/alpha-linux/2.95.2
ccc: Error: No source or object files specified on the command line

   The *very* conservative user would check, if the include and library paths
   given in this message really exist.
   Another ( my favourite way ) is to compile a *really* complex prgram, like:

   #include <stdio.h>
   	printf("Hello World\n");

   Compile it, using:

   ccc -fast ccc-test.c -o ccc-test

   using the resulting binary, called ccc-test should produce the very 
   informative diagnostics output:

   Hello World

   If all that happens, you are set.

Have fun and write free programs !

If you should have problems, feel free to contact me at kirk@colinet.de 


- IT

Reply to: