[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]



Well, I finally got around to testing the bootfloppies you pointed me to. I
must say that I'm really pleased and would like to thank all involved, as
it stands they are a huge improvement over the slink ones.

I've only tried installing the base system but it seems to have gone pretty
flawlessly apart from not being able to install aboot on the hard disk. I'm
not sure why this is, I have a correct BSD disklabel with partition 'a'
starting at cylinder 3, giving about 2 MB of space for the bootloader.

The only messages I see in syslog from dbootstrap are:

dbootstrap[26]: lseek #2 on disk
dbootstrap[26]: aboot wasn't able to install ...

I tried creating a disklabel without the 'c' partition spanning the whole
disk just to see if that was the problem, but it didn't help.

BTW. One thing that confused me in aboot-0.7pre1 is that if you mistakenly
try to boot a kernel with arguments the "old" way, i.e.

n/kernel args

aboot will silently go ahead and boot pre-configured kernel 'n', ignoring
your arguments. Of course if you do a 'b /kernel args' it works fine but
putting an extra check in might save some confusion.


Martin Lucina http://www.kotelna.sk/mato/ Wellington, New Zealand
I've always been mad I know I've been mad like the most of us are 
Pretty hard to explain why you're a madman even if you're not mad

Reply to: