[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: disks-alpha-20000329

Martin Lucina <mato@kotelna.sk> writes:

> I've only tried installing the base system but it seems to have gone pretty
> flawlessly apart from not being able to install aboot on the hard disk. I'm
> not sure why this is, I have a correct BSD disklabel with partition 'a'
> starting at cylinder 3, giving about 2 MB of space for the bootloader.
> The only messages I see in syslog from dbootstrap are:
> dbootstrap[26]: lseek #2 on disk
> dbootstrap[26]: aboot wasn't able to install ...
> I tried creating a disklabel without the 'c' partition spanning the whole
> disk just to see if that was the problem, but it didn't help.

Uh oh ... the problem is that it's looking for an existing boot
sector, and getting random data which evidently is causing it to
either seek past the end of the disk, or try to write the boot sector
in the middle of a partiiton or something.

I think this might be my fault, too :(

Time for an aboot 0.6b I guess.

> BTW. One thing that confused me in aboot-0.7pre1 is that if you mistakenly
> try to boot a kernel with arguments the "old" way, i.e.
> n/kernel args
> aboot will silently go ahead and boot pre-configured kernel 'n', ignoring
> your arguments. Of course if you do a 'b /kernel args' it works fine but
> putting an extra check in might save some confusion.

Oops! Yeah, it's the world's lamest command interpreter, it just looks
at the first character of the line.  I could probably hack it up more
so that it would understand the old way of booting.

David Huggins-Daines, Senior Linux Consultant, Linuxcare, Inc.
613.562.1239 desk, 613.223.0225 mobile
dhd@linuxcare.com, http://www.linuxcare.com/
Linuxcare. Support for the revolution.

Reply to: