[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Ghostscript troubles

    I'm trying to make my AS200 print again after a long period of
non-functionality.  During an update a couple months ago Ghostscript started
producing errors rather than printed pages, and now I'm trying to track it
down.  Uninstallation, purges, and reinstallation of gs, libpaperg,
apsfilter, and the like have had no effect.
    The printer is an HP LaserJet 6P, connected to /dev/lp0.  Printing ascii
text works just fine.  I've tried using the ljet4, lj5mono, and lj5grey
drivers in ghostscript, all with similar errors.

Here is what I get when I attempt to print a test page in apsfilterconfig:

Printing Test page using: cat /usr/lib/apsfilter/setup/test.ps |
gs -q -r600x600 -dBitsPerPixel=1 -sDEVICE=lj5mono -sPAPERSIZE=letter -dNOPAU
SE -dSAFER -sOutputFile=/tmp/fileNZQuVO -
Ok, to print testpage ? [y/n] y
Creating test page... Unrecoverable error: rangecheck in setcolorscreen
Operand stack:
    --nostringval--  45  106  --nostringval--  90  106  --nostringval--  15
106  --nostringval--  75  106  true

Unexpected interpreter error -15.
Error object: (f80)op(106:setcolorscreen)0x1200321a0
Operand stack at 0x1202cbb38:
[ ...stack dump continues...]

This is of course accompanied by four unaligned traps on the console, but
those were present when printing worked.

I'm tempted to do a wipe and reinstallation but I have a lot of time
invested in this machine and I thought I should ask here before doing so.
Has anyone seen a problem like this before?


Matthew R. Briggs
mbriggs at switchboard dot net

Reply to: