[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: brltty netinst floppy

"Mario Lang" <mlang@debian.org> writes

> Before I do anything speakup related with d-i, the release-critical
> bugs on kernel-image-2.4.20-speakup need to be fixed.  According
> to those reports, the precompiled package does not work at all.  This
> is not really acceptable as a base for further d-i work...

I got a Sid system somewhat running and tried this kernel on it. With
sighted assistance I was able to see that there is a kernel panic and read
the message. I can do it again and write the exact error for you if you'd
like. It was that the root filesystem couldn't be mounted and to append the
correct root mount point on the command line. Lilo already does this, but I
tried explicitly appending it myself anyway. Same panic message. Other
kernels do boot fine.

I don't know what's causing it, but here are a few possible suggestions. I'm
by no means a speakup expert in the least though, you may want to ask on the
speakup mailing list.
What version of speakup are you using? There is a new version 1.5 you can
download. There are also many changes in the latest cvs version. Two
notables are much better cursor tracking, and the synthesiser drivers are
now modularized. I'm not sure if it fixes your problem, but they say it was
a major code rewrite so it's very possible. Kirk says there are still some
bugs. From what I've seen personally and heard on the list there don't seem
to be any big problems though. I used it myself on slackware 9.0.



Reply to: