[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Kernel 3.2.0-3-amiga & cirrusfb

Geert Uytterhoeven dixit:

>> Just trying to get kernel 3.2.0-3-amiga to work on one of my Amigas (A4000T)....

That's a Debian ABI number, this 3.2.0-3 (they can only use x.y-ABI
after wheezy is out, for compatibility/upgradability reasons). The
kernel version for that is probably 3.2.21 plus Debian patches.

>That one doesn't have my cirrusfb probe rewrite and fixes?
>You need at least 3.3 for that.

This smells like another patch for the stable series coming up?

(Note that the cmpxchg fix is now queued for 3.2.27 and other
stable series so that way is definitely a possibility; the
Atari interrupt also seems to be queued… so we can really keep
using the Debian kernels, modulo hardware drivers – fixes for
these can probably go in via stable, and EtherN* backports,
once accepted in mainline, might go in via Debian directly,
if we can convince the maintainers.)

>Does it work if you update drivers/video/cirrusfb.c to the latest version?

Could be tried. Can you compile or cross-compile yourself? (For the
latter, I put the cross-toolchain into an APT repository.) Best is
probably to take the Debian source package, add a patch and just
build one kernel flavour. (I did so when the cmpxchg fix came up.)

15:39⎜«mika:#grml» mira|AO: "mit XFree86® wär’ das nicht passiert" - muhaha
15:48⎜<thkoehler:#grml> also warum machen die xorg Jungs eigentlich alles
kaputt? :)    15:49⎜<novoid:#grml> thkoehler: weil sie als Kinder nie den
gebauten Turm selber umschmeissen durften?	-- ~/.Xmodmap wonders…

Reply to: