[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Linux/m68k on Atari


> With the coming soon CTPCI (PCI expansion board for Atari Falcon+CT60),
> I decided to give Linux/m68k a try.
> Unfortunately, no kernels I tried on the CT60 seem to work, I just get
> a black screen, and then reboot after a few seconds (for the atari
> flavour of m68k kernels).
> The one I tried is:
> http://people.debian.org/~smarenka/d-i/m68k/images/daily/kernels/vmlinuz-2.6.26-1-atari
> with the bootstrap program from:
> http://people.debian.org/~smarenka/d-i/m68k/images/daily/tools/atari/

While I probably haven't tested that particular one, I am fairly certain that 
Stephens kernels did work. 

The bootstrap should be renamed to ataboot.tos - I had weird errors when running 
it as a GEM app. 
> The same kernel works on Aranym. Any idea, hint?
> The Falcon is plugged on my PC using Null-modem, so maybe I can debug
> through serial port?

Yep - add debug=ser to the kernel options and capture the output. Serial 
settings should be 9600 Baud 8N1 IIRC. If nothing is shown on the serial port 
you may need a patched kernel to show output from the early kernel init stages. 
That hasn't been necessary in quite a while now. 

Maybe try booting in ST-High video mode (video=atafb:sthigh if memory serves me 

I'm assuming you use a IDE disk - that should work quite stable actually. 

Post your serial log here or send it to me by mail. I'll have a look at it.


Reply to: