[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: binutils, gcc-4.2, gcc-4.3, gcc-snapshot builds


> > EtherNAT driver, and ARAnyM did not work on my Powerbook last time I
> > tried. I'm stil planning to work on it, come next month.
> Speaking of which, debian linux 2.6.22-4 gives me some of the following
> errors when using aranym.
> | blk_queue_max_hw_segments: set to minimum 1

Yep, I encountered that one from 2.6.14 on or so - submitted a patch for
this I think. It's due to our SCSI drivers setting one of the host
parameters to zero (has a special meaning internally in the driver but the
midlevel gets confused). It's no can_queue or cmd_per_lun but I cannot
remember the name right now.

> And a whole ton of the these errors.
> | ide_release_lock: bug

Yup, that one does not seem possible to fix properly without achieving a
really deep understanding of the IDE driver (yuck). Not going there if I
can help it :-)

> However, it boots to the prompt fine, much better than 2.6.21-4. It
> still doesn't detect the ethernet device, so no network. When booting
> from an initrd (think d-i), the framebuffer still goes all wonky.

The natfeats ethernet driver may have been missed in some ethernet driver
updates (parameter list of the inthandlers changed some way back as far
as I remember), or even be missing. Gert should know what I'm talking
about, hopefully.


Reply to: