[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X on Mac (was: Re: upgraded to lenny/sid and ordered RAM)

Brian Morris wrote:
> I have X work ing (or more than half way anyway) !!
> see below.
Hey Brian,

I'd be curious about some of your other findings on X.  I have Woody or
Sarge installed on 2 Quadra 840avs, a Q700, and a Q630 motherboard in a
PowerMac 5200 all-in-one case (to save workbench space).  On all of
these systems, I get no key repeat in X.  Works fine on the console.  A
while back I put some time into experimenting with all the keyboard
configurations and settings available in XFree86 4, and pretty well
convinced myself that something is broken, and it is not just my
configuration.  A couple weeks ago I thought I'd try installing my old
CheapBytes Potato CDs (which I once installed on a IIci) on a Q700 to
see if the same issues arose in XFree86 3.2, but ran into trouble
reading the CDs and couldn't get X installed properly.

So I'm curious to know whether the same problem shows up in X.org.  You
mention that the cursor keys don't work -- are you sure the keys don't
work at all, or do they just not repeat like you would expect?  In XF86
4 on Woody or Sarge, I can open an xterm, or really any window or
program that allows you to type, and hold down any key all day long and
get only a single keystroke.  If I switch to a virtual terminal, holding
down a key works as expected.

Another keyboard oddity I experience is that caps lock doesn't toggle on
and off with a single keypress.  This is probably related to the old,
old ADB keyboards that had a latching caps lock key.  I have some of
those, so I should try one and see if they work right.  But with a newer
keyboard, you have to hit "Caps Lock" two or three times to switch back
and forth.  And the indicator LED isn't properly synchronized with the
caps lock state.  Or something like that.

Someone on this list recently suggested I try a 2.6 kernel, which I
intend to do, but it sounds like you have beat me to it.  What are your

As for the framebuffer strangeness and color depth support, I think that
perhaps Linux only knows how to change the bpp for some of the Mac
models, and for others you may still have to change the setting in MacOS
and boot with Penguin.  Emile has us so close to being able to do
without MacOS entirely -- but perhaps not quite yet...  More comments below.

> On 5/17/07, Finn Thain <fthain@telegraphics.com.au> wrote:
> ...
>> >
>> >   128MB Apple Performa 630 Series 72-pin SIMM (p/n APL72P128)
>> >       $49.98          1       $49.98
>> > 64MB PowerMac 6100, Performa, Quadra 72-pin SIMM (p/n
>> > APPLE-64MB-FPM-SIMM)  $19.98  1       $19.98
>> >
>> > (I think I spent too much)
>> Well, perhaps not if we can fix xorg ;-)
>> > > > i have tried X and i got some initial screen but it is only about
>> > > > 2/3 of the way down and then it is overdrawn or something (whitish
>> > > > color with stripes) and hangs the console. I had done several
>> > > > install of both xfree and xorg on powerpc so I think I know if
>> it is
>> > > > not apparently working. could it be problem with the framebuffer
>> > > > driver. the xorg fbdev uses another driver called something like
>> > > > fbhw or hwfvdev something like that.
>> > >
>> > > That sucks. Was this the 630? I'd be curious to see your
>> xorg.conf and
>> > > xorg.0.log (not that I would know how to fix it, I just wanted to
>> > > compare with ljmoore's...)
>> >
>> > yeah, i have not tried the 605 much at all. (it still has just a
>> minimal
>> > Sarge install on).
>> >
>> > i will go back and try X once more, and whatever happens i will bring
>> > back the conf and log files. i just remembered where i used fbdev as
>> > driver before somewhere, that I can look at the options.
> It works !! more or less. I took 5 minutes to start the first time, i was
> just sitting there dozing. it took a long time the first time to start
> the window
> manager even longer than the server.
What window manager are you using?  I've used IceWM to pretty good
effect.  When I installed Sarge on my Q630 (booting from Emile on CD,
and overwriting MacOS on the HD) I put on Fluxbox, after having had good
experiences with Damn Small Linux on low-end x86 PCs.
> problems :
> 1) it refuses to believe i have more than 300k of video ram. I know i
> have
> at least 640x480x2 bytes, upward of 512k...
>   but it will only go in 640x480x1 Byte not 640x480x2 or 800x600x1 as
> in macos.
I've got my Q630 doing 800x600x8 right now in X under Sarge, so I can
confirm that the hardware is capable of that.  When I boot I need to
pass the following parameter to the kernel:  video=valkyriefb: (note
that the colon on the end is significant.)
> 2) most apps that have both X and console versions won't start their
> X versions. for instance xemacs -nw works but not xemacs, info and w3m
> produce their text versions in the window you type but do not start
> from the menu (on ppc both ways give you new windows). but graphicsmajick
> xedit xman all work so i don't know what's up.
I don't have xemacs or w3m, but I can confirm that in Sarge, info just
runs in an xterm and doesn't produce an X window.
> 3) the cursor keys don't work in X.
> it could be a memory problem. i was running xemacs in an xterm and
> loading html rendering hypertext with w3m mode and it was only swapping
> moderately (about 10MB).
>> >
>> > another thing that kinda sucks is the fbdev driver does not support
>> 1, 4
>> > bit. (it speeds up the old machines quite a bit).
>> Yeah, 8 bpp can be really slow on some macs. I never did much testing of
>> different video settings on fbdev though. But ISTR that 4 bpp worked on
>> some of my macs...
This is why I'm itching to make one mac an X terminal and another one an
app server.  I'd like to boot the X terminal from Compact Flash, which
would suggest the Q630.  But I can get 2M of VRAM in a Q700, which has
SCSI, but no IDE interface.  So CF would be out on that one.  Probably
VRAM trumps solid state boot disk for an X terminal.  I'd like to try
freeNX to see how that effects performance.  Screen updates might still
be slow, but at least the apps could keep chugging along while the other
machine fiddles around with the graphics.
>> Was this a regression in linux 2.6 on your Q605/sarge box? Or does
>> neither
>> the 2.2 nor 2.6 kernel support 1 bpp or 4 bpp fbdev (on either mac)?
> I have not tried Xfree on 68k (on Sarge) and am now Xorg stuck with 2.6.
> (but I tested 1bit video with Xfree4.4 on netbsd68k november2006 release)
I've got your Xfree Sarge covered.  If I get some time this weekend
maybe I can check out different bit depths in X for comparison.
> Anyway looks like
> its the fbdev driver in/with xorg that does not support below 8bit color.
> or else the fbdevhw thing that it calls, i don't know all i know is i
> tried
> it and X told me " ... not supported ".
Try fbset to see if you can change the bit depth / resolution in the
console.  If you really want to test it out, download fbi, which is a
framebuffer image viewer.
>> -f
>> > I should try the 605 though because i found i am able to get
>> 1024x768 on
>> > that but only in 4bit unless I add vram.  i don't know maybe that is
>> > another regression if i upgraded i would lose the 16bit support ?
>> it is
>> > not costly though like the other RAM. it would be nice actually to put
>> > the VRAM in to get 8bit at 1024x768. it is nice even in 4 bit. 
>> anyway I
>> > should try that is is simply a matter of copying the 630 install to a
>> > spare external drive, and hooking it up.

Reply to: