[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to install without d-i

On Wed, Aug 17, 2005 at 11:35:26PM +0200, Petr Stehlik wrote:
> Wouter Verhelst píše v St 10. 08. 2005 v 23:46 +0200:
> > Yes. Just boot the system in single-user mode and run the
> > /native-install manually. It might have to be ran twice; if so, it'll
> > tell you. Once it's completed (the second time, if appropriate), you can
> > simply remove it.
> It was complaining a lot about missing group ID when it was creating
> devices in /dev/. Later I found out that /etc/group is not there.
> Something didn't work as expected.

No, that's normal; /dev/group is created in the postinst script of the
shadow package.

That's why you need to run it twice. Didn't it mention that?

> > > > I've tried running Linux on aranym the other day, but when I run
> > > > 'aranym-mmu -l -N' after fiddling with the configuration file to point
> > > > to the right kernel and initrd, it dies with "CPU: Double bus fault
> > > > detected !", and "CPU: Halting". Any hints?
> > > 
> > > Looks like you let it execute something else than a m68k binary.
> > 
> > No, I'm quite sure I didn't. I tried feeding it both the Woody and the
> > Sarge installation kernels (and initrds)
> Have you been using the integrated LILO? I have pretty exact information
> about booting linux in the doc/documentation.txt.

Yes, I've seen that information, and I followed it pretty vigorously. At
least I think so; I'll probably revisit it again sometime this week,
just to be sure.

> > > What's your host hardware?
> > 
> > A PowerPC G4 (my laptop). I haven't tried on Intel yet. Maybe an
> > endianness issue? Just guessing here.
> no. The ARAnyM MMU was debugged by Andreas on PPC Mac.

Okay, then that shouldn't be it.

> BTW, I tried installing Debian Woody, it workd perfectly but now it
> freezes during boot at
> VFS: Mounted root (ext2 filesystem) readonly.
> Adding Swap: 137796k swap-space (priority -1)
> ttyS0 at 0xfffffa01: MFP
>     ^^^ this is the last message, then it freezes
> I am wondering if there is something wrong with MFP or if it's some
> other problem.

Not sure either.

The amount of time between slipping on the peel and landing on the
pavement is precisely one bananosecond

Reply to: