[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: how to install without d-i

Wouter Verhelst píše v St 10. 08. 2005 v 23:46 +0200:
> > > Once that's done, just make a directory somewhere, and run "crosshurd"
> > > as root. Point it to the directory you've just created, choose
> > > "linux-hurd" as system type, and "m68k" as processor. That's it.

> > Does the /native-install script mean that I should run it?
> Yes. Just boot the system in single-user mode and run the
> /native-install manually. It might have to be ran twice; if so, it'll
> tell you. Once it's completed (the second time, if appropriate), you can
> simply remove it.

It was complaining a lot about missing group ID when it was creating
devices in /dev/. Later I found out that /etc/group is not there.
Something didn't work as expected.

> > > I've tried running Linux on aranym the other day, but when I run
> > > 'aranym-mmu -l -N' after fiddling with the configuration file to point
> > > to the right kernel and initrd, it dies with "CPU: Double bus fault
> > > detected !", and "CPU: Halting". Any hints?
> > 
> > Looks like you let it execute something else than a m68k binary.
> No, I'm quite sure I didn't. I tried feeding it both the Woody and the
> Sarge installation kernels (and initrds)

Have you been using the integrated LILO? I have pretty exact information
about booting linux in the doc/documentation.txt.

> > What's your host hardware?
> A PowerPC G4 (my laptop). I haven't tried on Intel yet. Maybe an
> endianness issue? Just guessing here.

no. The ARAnyM MMU was debugged by Andreas on PPC Mac.

BTW, I tried installing Debian Woody, it workd perfectly but now it
freezes during boot at

VFS: Mounted root (ext2 filesystem) readonly.
Adding Swap: 137796k swap-space (priority -1)
ttyS0 at 0xfffffa01: MFP
    ^^^ this is the last message, then it freezes

I am wondering if there is something wrong with MFP or if it's some
other problem.


Reply to: