[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt-get problems on Quadra 610



I hope I'm in the right list for this kind of question...

Okay, so I'm a Mac user who has decided to get his feet wet in linux. Totally new to this so if you've answered this question a thousand times please bear with me.

I have several old Macs lying around and I thought I'd start with the oldest and see if it could be used for something other than a doorstop.

The machine is a Quadra 610  25 MHz 68040 with 44 MB of RAM, 230 MB HD

I have installed debian 2.2 for mac68k and seem to have everything running. I am connected to the internet via DSL through a DSL router acting as a NAT box using DHCP.

My problem is apt-get. The first time I tried running apt-get update it seemd to be taking an awfully long time, over 36 hours to be precise. I type the command and the cursor moves down one line and just blinks, that's it, for 36 hours.

A friend suggested I open another console and use top to see if anything was happening. Sure enough, apt reports as running (the only thing running everything else is sleeping) and the clock is merrily ticking away but nothing seems to be happening.

I thought perhaps it's just that it's a slow old machine and the ethernet is only 10-base-T (and there are a lot of packages) but when I quit and tried some other commands like apt-cache pkgnames, I have the same problem, just a blinking cursor. Shouldn't that at least show me that I currently have very few packages on my system? And, shouldn't that take a relatively short time to display?

To confuse me even more, when I run apt-setup it successfully finds the debian ftp servers logs in and indexes the package lists. I also succesfully used FTP to download a 3.5 meg file to the Quadra in less than a minute. So I know I can connect to an FTP server and I know it can download relatively quickly.

I tried updating to a newer version of apt including all it's dependencies (and all their dependencies) No fun when you do it manually. Still no go. Then I updated the kernel to 2.2.20. Still nothing. Now I'm thinking that probably wasn't a good Idea because I have some older packages and some newer packages and a newer Kernel. If only I could run apt-get upgrade!

There were no glitches during the installation process to suggest a corrupted file or something.

There must be something obvious I'm missing with my configuration somewhere. Can anyone help?

-Kelvin



Reply to: