[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get problems on Quadra 610

On Thu, 16 Sep 2004 krempel@nextsteps.org wrote:

> ...
> The machine is a Quadra 610  25 MHz 68040 with 44 MB of RAM, 230 MB HD

With 44 MB of RAM, you shouldn't be using much swap space... but I can't
be certain. You can check your swap stats with vmstat (or look in

> I have installed debian 2.2 for mac68k and seem to have everything
> running. I am connected to the internet via DSL through a DSL router
> acting as a NAT box using DHCP.
> My problem is apt-get. The first time I tried running apt-get update it
> seemd to be taking an awfully long time, over 36 hours to be precise. I
> type the command and the cursor moves down one line and just blinks,
> that's it, for 36 hours.

Maybe some sort of timeout (dodgey disk, DNS, network timeouts/retransmits
... I'm guessing). You can get network error stats from netinfo and

You should check dmesg (or your kernel log file over the period in

> A friend suggested I open another console and use top to see if
> anything was happening. Sure enough, apt reports as running (the only
> thing running everything else is sleeping) and the clock is merrily
> ticking away but nothing seems to be happening.

Was apt-get at 100% cpu for the duration? Was the total CPU score?

> I thought perhaps it's just that it's a slow old machine and the
> ethernet is only 10-base-T  (and there are a lot of packages) but when
> I quit and tried some other commands like apt-cache pkgnames, I have
> the same problem, just a blinking cursor. Shouldn't that at least show
> me that I currently have very few packages on my system? And, shouldn't
> that take a relatively short time to display?

Does it ever complete? If so, you could try "time apt-cache pkgnames" to
find out whether the job is CPU bound.

> There must be something obvious I'm missing with my configuration
> somewhere. Can anyone help?

Can't see anything "obvious".


> -Kelvin

Reply to: