[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MacAlly 2-button ADB mouse?


Try to use -Rms3 instead of -Rmsc, and set the Protocol field in your XF86Config
to "Microsoft".
I hope this will work.


mformica2 wrote:

> I finally at long last got gpm working in terminal using 'gpm -m
> /dev/adbmouse -t bm -Rmsc' - and setting XF86Config to use the MouseSystems
> protocol.  I tried PS/2 (with the appropriate protocol in the XF86Config
> file), but that didn't work at all in terminal or X.  I do repeat things
> into /dev/gpmdata, and I have /dev/mouse pointing there as well.  The
> problem is this:  I'm still not getting the 2nd mouse button on my MacAlly
> 2-button mouse.  gpm is working because I have X looking there and the first
> button works, but as soon as I change the -R setting gpm stops working, and
> of course X doesn't like it either.  Any ideas on what's wrong?
> Matthew
> > From: Gyurko Szabolcs <szabolcs.gyurko@sysdata.siemens.hu>
> > Hi !
> >
> > Yes, I think you should. If the gpm can handle your mouse correctly under
> > terminal,
> > you can enable the repeater, and change your /dev/mouse link to point to
> > /dev/gpmdata.
> >
> > /dev/gpmdata will be a device, and gpm puts the datas incoming from mouse to
> > this,
> > and X server can read from it.
> > In this way you can do some protocol translate too. (eg: you can set your
> > repeater
> > to produce PS/2 compatible data output to /dev/gpmdata. In this case you can
> > configure your X server for PS/2 mouse).
> >
> > Bye.
> >

Reply to: