[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bad media?

Lourens Veen wrote:
On Wed 8 October 2003 20:28, Gregoire Favre wrote:

a DVD burn ended like this:

Track 01: 4387 of 4449 MB written (fifo  99%) [buf 100%]  
See below.

Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 21ac4
Information about the disc.

2277945 extents written (4449 Mb)
Track 01: 4431 of 4449 MB written (fifo 100%) [buf  94%]
This means that it stopped on the first track, after having written 
4431 of 4449 MB. The fifo queue (between cdrecord and the drive) 
was 100% full, the buffer (in the drive) was 94% full. If this were 
a buffer underrun the buffer would have been empty (0%).

2.0x.cdrecord-prodvd: Input/output error. write_g1: scsi sendcmd:
no error
There was an Input/output error when writing. This is a very generic 
error message, that doesn't say much other then that something went 
wrong. The last SCSI command (write_g1) was sent to the drive 
succesfully (the "scsi sendcmd: no error" part), but there was a 
problem executing it.

CDB:  2A 00 00 22 9F F1 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: F1 00 03 00 22 97 29 12 00 00 00 00 0C 08 00 00
Sense Key: 0x3 Medium Error, deferred error, Segment 0
There was an error in the medium (ie the disc). 0x2 and 0x3 are the 
SCSI status codes.

Sense Code: 0x0C Qual 0x08 (write error - recovery failed) Fru
0x0 Sense flags: Blk 2266921 (valid)
It tried to recover from the write error, but that didn't work.

cmd finished after 0.002s timeout 100s
The SCSI command finished after 0.002s (with an error).

write track data: error after 4647258112 bytes
We wrote 4647258112 bytes and then the error occurred.

cdrecord-prodvd: A write error occured.cdrecord-prodvd: Please
properly read the error message above.
This message stems from Jörgs belief that all users are familiar 
with the internals of CD writing and can decipher it. I've picked 
up some stuff from reading this list for a long time and browsing 
through the entire set of documentation for cdrecord and associated 
programs to classify them for the new website, but I'm not sure 
I've got it 100% correct either.

Writing  time: 1758.609s
Average write speed   1.9x.
Min drive buffer fill was 93%
Some statistics about the burn.

Fixating time:    0.000s
The disc was fixated.

cdrecord-prodvd: fifo had 73483 puts and
73200 gets.
cdrecord-prodvd: fifo was 0 times empty and 15373 times full, min
fill was 97%.
Statistics about the fifo queue between cdrecord and the drive. It 
wasn't empty, so it's not a problem with your computer being too 
slow to feed the drive data.

Is it a bad media (I don't understand the message)?
Probably, yes. It could always be a firmware problem or a bug in 
cdrecord, but those are both very unlikely.
Thanks for the nice breakdown of the message, although since the time was zero I wouldn't bet that the media was fixated. I have been seeing a bunch of these lately writing audio. The media I use work very well for data, and not only don't get errors writing, but have excelent to perfect results when I run a c2check after a burn (I do, on critical data like backups).

I tried updating the cdrtools to the latest, and even running a stock kernel, but it doesn't make the process more reliable. I did see that failure was much more common with the -v option, five in a row failed using that, two of three worked without -v. Note: that's a bit of data which is interesting but too small a sample to be statistically reliable.

I will try so other media next week, I have some "free after rebate" no-name media to use, it's only 650MB but the price was right.

Now is I could fine a good program to let me record a tape side as a single wav file and easily break it up and fill in the inf files later... anyway, I'm transcribing a ton of old tapes, so audio without hassle is a requirement, I will buy a pack of brand name later today as well.

E. Robert Bogusta
  It seemed like a good idea at the time

Reply to: