[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X kills my powerbook

On Thu, Mar 09, 2006 at 10:48:26AM +0100, Michel Dänzer wrote:
> On Thu, 2006-03-09 at 10:00 +0100, Sven Luther wrote:
> > On Thu, Mar 09, 2006 at 03:37:35PM +1100, Benjamin Herrenschmidt wrote:
> > > 
> > > > Known bug in xorg 6.9, try to go back to 6.8 if you can. 
> > > > I don't know if 7.0 is ready or not (it is in experimental
> > > > but not yet built for PPC).
> > > 
> > > I've fixed a lot of those problems in X.org CVS, I don't know if distro
> > > picked them up yet, though you'll need 7.0 to run the fixed radeon
> > > driver.
> > 
> > This is not yet fixed in debian though, so right now we don't have a working X
> > in those cases. 
> > 
> > Dear X team, could you maybe comment on when this fix will be added to the
> > modular X tree, at least in the experimental version ? 
> The patch is included in xserver-xorg-video-ati SVN but hasn't been
> uploaded to experimental yet. Ironically, it's incorrectly called
> 'ppc_fix.diff'.

Xorg has switched to SVN? I have the CVS repository but I 
never heard of a subversion one. 

Besides that Ben claimed that he had checked in patches to
Xorg's CVS tree IIRC.

At least I can more or less understand subversion, I always
had a tremendous impedance mismatch with CVS :-)

> First we need to verify that it fixes the issues with newer PowerBooks,
> then we can worry about backporting.

Trying to compile Xorg's CVS right now, will let you know
if I succeed for the first time in my life ;-) 

Since the fixes are from Ben, I suspect that it 
"just works" (TM) :-)


Reply to: