[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kdm and Xfree4.3 not playing nice together



On Wed, Mar 19, 2003 at 11:38:51AM -0800, Per Peterson scrawled:
> OK, so I'm a noob to Debian, but not to Linux or
> Xfree86 or kdm screwing up.  Before this week I was
> running RedHat, but I wanted to be able to switch to
> KDE 3.1 and Xfree 4.3 and I figured that switching
> distributions to Debian would be my best bet. 
> Installed the latest pakages in sid, including kde 3.1
> with the kdm package and Xfree86 4.2.1.  Everything
> went well with just a little manual configuration for
> gpm, grub, and a few other packages up until I tried
> to start an X server.  It was a strange psychadelic
> look when X actually came up (this was after a lot of
> playing with the XF86Config-4 file).  It showed a
> color negative of the boot screen for my Thinkpad T22.
>  Apparently this screen is stored in the video BIOS on
> my Savage/MX-IV (And yes, I read all the problems with
> Savage/MX-IV cards in Thinkpads; none of it answered
> the question.)  The X font server was working and
> could draw text to the screen and libpng was working
> and could draw pngs to the screen.  Gtk, qt, libjpeg,
> xwrapper -- none of them were working Everything acted
> like nothing was wrong.  Its just that the only output
> that I saw was text and pngs.  (Believe me, kde looked
> far out; you should see what kde looks like without
> any qt widgets being able to be rendered.) 
> Importantly, though, kdm worked; it just looked a
> little weird.

Define "a little weird".

Also, while it is very strongly recommended you stick with 4.2.1, 4.3
packages are available from http://penguinppc.org/~daniels/xfree86.

>         Now, I know that Xfree86 4.3 is not supported
> by
> debian and there's a reason why sid comes with 4.2 not
> 4.3, so don't write back saying that I should have
> stuck with the 4.2 package.  Its just I think that
> debian must put something special in one of the config
> files for Xfree that makes it run right with kdm, and
> since I stupidly overwrote all the Xfree86
> configuration files when I installed the new version. 
> I'm just wondering if anyone knows what happened
> and/or how I can fix it.

We can't support what you don't package; if you insist on using binaries
created by someone other than us, then you'll have to report the bug to
then.

-- 
Daniel Stone                                     <dstone@trinity.unimelb.edu.au>
Developer, Trinity College, University of Melbourne

Attachment: pgpWQznJqQ5aZ.pgp
Description: PGP signature


Reply to: