[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: voodoo3 libgl error in woody xf4

Thanks for your info...

however, last night... in my frustration... i purged my entire X
installation, and found that i did actually have a couple old GL
libraries from my previous compilation (i thought i had removed all of
them, but apparently not).

anyway, i'm happy to say i have an entirely deb based system (except for
the 2.4 kernel i compiled) with working xf4 and dri on a voodoo3 (no need for alien etc.)

kudos to Branden et al!

On Fri, Nov 10, 2000 at 10:57:33PM +0500, James Leigh wrote:
> > Greetings,
> > 
> > i have recently installed the woody xf4 debs my system with a voodoo3
> > card and things are working fine, except for opengl acceleration.
> > 
> > my kernel: 2.4.0-test10 w/ tdfx compiled into the kernel (and agppart
> > enabled)
> > vid card: voodoo3 2000 agp
> > mobo: asus a7v
> I was hoping that some one else would respond with a better answer then
> this, but since no one has, I will let you know what I have done to get
> my voodoo3 xf4 and kernel-2.4.0 to work.  At the linux.3dfx.com site
> they have three binary rpms for OpenGL API , tdfx-dri, tdfx-drm, and
> glide-v3-dri.  The tdfx-drm you have included in your kernel so you will
> not need this, but you have to install the other two.
> Install alien to convert the two rpm packages into debs.  The
> glide-v3-dri installed on my system without any trouble, the tdfx-dri
> directly conflics with the xserver-xfree86.  This is why it is not a
> great solutions, but it works.  Install the tdfx-dri over the
> xserver-xfree86 deb.  Use dpkg --force-overwrite -i tdfx-dri.deb.  You
> will have to overwite the xserver-xfree86 every time up upgrade it.
> I use voodoo3 xf4 and linux-2.4.0 w/ voodoo3.  This method works for me;
> I hope it will help.
> http://linux.3dfx.com/open_source/download/voodoo3_banshee_dri.htm
> james

Reply to: