[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Trouble with DRI on G200

Hi All,

I'm trying to get DRI working on my Matrox G200 and not having much
luck.  Most of this is probably due to my ignorance of Linux 3d
support, but since it involves Debian specific changes to X, I thought
I'd ask here first.

I first tried using the stock 4.0.1-0phase2v13 X packages with kernel
2.2.18pre15 and got the following message from the X server:

(EE) MGA(0): [drm] MGADRIScreenInit failed (DRM version = 1.0.0,
expected 2.0.x).  Disabling DRI.

It seems the Debian diff for 4.0.1-0phase2v13 has patched the mga_drv
X module to require a newer version of the mga kernel module, which
AFAICT, is only available in the 2.4 kernel.  I'd rather not switch to
the 2.4 kernel yet.  Does anyone know of a newer version of the mga
kernel module for the 2.2 kernel?

I then tried replacing the mga_drv X module with one from the Matrox
ftp site that appeared to work with the 1.0.x mga kernel module and
got the following messages:

(0): [drm] installed DRM signal handler
(0): [DRI] installation complete
(II) MGA(0): direct rendering enabled

However, glxinfo claimed direct rendering was not enabled, and sure
enough, there was no improvement over software renedering when running
3d apps.

FYI, another partly related problem I've run into is that the mesag3
package contains libGL and libGLU but the xlibmesa3 package only
contains libGL.  What package is supposed to provide libGLU when
xlibmesa3 is used?

David Engel

Reply to: