[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: repeat of previous question that has gone unansweredseveraltimes.

Printing on Linux is poor.  CUPS is poor.  It doesn't work for some (a lot?) of people.

I have a Brother HL-L2300D printer.  It is connected to my (Debian bullseye) workstation by USB.  I have CUPS installed.

My printer prints sometime.  Other times, it spins up (makes a noise like it is about to start printing), but nothing comes out. I can't get any useful diagnostics to tell me where the problem might be.

My parents, who live some distance away have an HP inkjet printer.  It works sometimes.  Other times it doesn't.  I get it set up so it's working and it might work for a while, but it will stop working for no reason.  There might be several queues for the printer; some work and some just don't.  A working queue will stop working for no discernible reason.  Working queues will disappear, new queues will appear seemingly at random.  The print system will default to an automatically provided queue that could never work, because it relies on some software component that is not installed.... etc... etc...

Between my parents and my own system, I have spent 10s or 100s of hours trying to get a reliable printing system over decades, with many different printers.  Maybe there were periods where printing worked OK.  But I haven't managed to achieve reliable printing in the medium term.

I read ESR https://www.catb.org/~esr/writings/cups-horror.html, and my personal experience is that nothing much has changed in the "driverless" era.

I've been a sysadmin for 30 odd years, configuring different aspects of linux (webservers, email servers, DNS, networking, desktop environments etc.) using open source software.  Some problems are difficult to solve, but I've always found that having a good basic understanding, checking logs, using tools to confirm what is happening, and doing research on how things work, allows me to solve those problems eventually.

Not so with CUPS and printing.  I have tried many different approaches (e.g. * reinstall from scratch, accept the default packages and default options.  * go to the linux printing site and follow the recommended method for my model of printer * try to understand how CUPS works, set up as statically and simply as possible, and use standard tools to troubleshoot printing failures.)  I have not succeeded with any approach.

It could be that I have struck certain models of printer with bugs.  Hardware and firmware bugs exist, and not just in printers.  However, I don't find hardware or firmware bugs cause me significant pain as there are normally software or configuration based work-arounds/allowances for them in Debian. Except for printers.  These same printer models work much more reliably in MacOS and Windows.

Back in the lpr/lpd days things were more reliable.

Is there a deeper problem affecting printing on linux?  I asked work colleagues and got two responses:

"oh, shit.  you’re actually printing from linux.  my condolences.', and

"I use Epson and Ubuntu, never had an issue with print over IP - so I can attest to drivers working from that perspective atleast"

My perspective is that there is a significant issue, at least for a portion of users.

Implying the user is at fault (which Brian isn't necessarily doing here,) or acting surprised when someone has trouble printing, is like gaslighting.  Maybe it works OK for you, but please understand that is not the general case.  Debian can't support every printer for every user, but knowing that, CUPS should come with a health warning:  "We supply this software as-is in the knowledge that it has known faults, and will not work reliably for all users.  We wish there were a way that Debian users could reliably print, but there is not.  You may get some help on Debian User, but in general printing is not supported."


On 6/05/23 05:45, Brian wrote:
Your conclusion is that the printing system is in itself is defective and that is
reflected in your response.

Reply to: