[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing anbox on Debian 10

Has anyone successfully installed anbox on debian. I have tried a couple of different ways starting with the debian stable package. The debian stable anbox package requires a lot of manual installation of support packages. I never did get things to work. I finally loaded the snap version which at least loaded all of the support packaging. Unfortunately, anbox still doesn't work. When I try to start anbox I get a white screen with the android logo in the middle. The screen disappears after a few seconds and then nothing. On a suggestion I ran "anbox session-manager" which gave me the following:

$ anbox session-manager
radeon: Failed to get PCI ID, error number -13
[ 2021-01-23 21:29:41] [Renderer.cpp:128@initialize] Failed to select EGL configuration
Stack trace (most recent call last) in thread 19805:
#7    Object "[0xffffffffffffffff]", at 0xffffffffffffffff, in
#6    Object "/snap/anbox/207/lib/x86_64-linux-gnu/libc.so.6", at 0x7f5a8209a292, in clone #5    Object "/snap/anbox/207/lib/x86_64-linux-gnu/libpthread.so.0", at 0x7f5a82421608, in #4    Object "/snap/anbox/207/usr/bin/anbox", at 0x55d218930f34, in emugl::Thread::thread_main(void*) #3    Object "/snap/anbox/207/usr/bin/anbox", at 0x55d21883df78, in RenderThread::main() #2    Object "/snap/anbox/207/usr/bin/anbox", at 0x55d21892bc80, in renderControl_decoder_context_t::decode(void*, unsigned long, IOStream*)
#1    Object "/snap/anbox/207/usr/bin/anbox", at 0x55d2188abfe2, in
#0    Object "/snap/anbox/207/usr/bin/anbox", at 0x55d2188aeea9, in RendererConfigList::getPackInfo(int*, int*) const
Segmentation fault (Address not mapped to object [(nil)])
Segmentation fault

I have no idea what is wrong. I have had no problems with my Radeon graphics card before and have a lot of packages that are graphics heavy. Any help will be sincerely appreciated. Please ask if any additional information is needed.

Gary R

Reply to: