[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apt dependencies

On 2020-12-05 at 18:48 +0000, Joe wrote:
> What does the >= sign mean as regards dependencies? I took it to mean
> 'this version or later', but apparently not.

It does.

> I've had a logjam on sid for a while now, so I thought I'd
> investigate.
> debfoster cannot be upgraded because of a dependency on guile-2.0-
> libs.
> guile-2.0-libs depends on libgc1c2 (>= 1:7.2d) but it is not
> installable.
> Currently installed version of libgc1c2 is 1:7.6.4-0.4.
> Why does this not satisfy '>= 1:7.2d'?

It does:

$ dpkg --compare-versions 1:7.6.4-0.4 '>=' 1:7.2d
$ echo $?

The issue seem to lie in that there are two different packages
guile-2.0-libs depends on libgc1c2 (>= 1:7.2d)
debfoster depends on libgc1 (>= 1:7.2d)
libgc1 conflicts and replaces libgc1c2

I think guile-2.0-libs would need to be changed to depend on libgc1,
but that will probably also require a rebuild, to link with the new

Reply to: