[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to boot new buster installation (SOLVED)



On 6/12/20 9:25 PM, David Wright wrote:
On Fri 12 Jun 2020 at 14:22:03 (-0700), Gary L. Roach wrote:
On 6/11/20 1:24 AM, Dominique Dumont wrote:
On mercredi 10 juin 2020 19:53:53 CEST Gary L. Roach wrote:
The sequence of events on boot up are Bios screen, Debian Window with OS
selection, Boot up sequence, login/password ( Xorg not running), startx
-> error window. So to answer your question, the message is after
login/password.
Right.. Looks like there's no display manager installed. Depending on your
favorite environment, could you install one of sddm, lxdm or gdm ?

On my side, I used sddm.

Question: Where is the file that contains the display setup (ie refresh
rate, resolution.)
This can be set in /etc/X11/xorg.conf in some cases (e.g. for nvidia
hardware). Now, most of the required information is retrieved from hardware by
Xorg. xorg.conf can usually be removed (except with nvidia driver).

Where would randr get its information if Xorg was
running?
>From Xorg process.

I would have responded sooner but have been hit with a severe case of
Vertigo.
No problem.

I think I have finally found the problem. Running "journalct -xb" and
running down the listing, I found that I was missing a Radeon video
driver. The driver is non-free and the installation disk doesn't setup
the sources.list for non-free downloads. So I'm in a catch 22
situation. When I install the net-install buster disk and switch to
recover mode the network is not available  and without the network I
can't get the firmware I need to get the system started. I've tried
the debian-live-10.40-amd64-kde+non-free disk and found it very
confusing. In short, it didn't work either. There is a firmware
package "firmware-amd-graphics"in the debian suit but without network
access I can't get at it.

If anyone could tell me how to start the network in rescue mode it
would help. Why is the network shut down in rescue mode in the first
place.
I can't quite follow why you need rescue mode. After the
login/password ( Xorg not running) in your sequence above,
just don't run startx. Then edit the sources list, adding non-free to
it. Now run apt or apt-get to update, and install the package.

$ sudo apt-get update
$ sudo apt-get install firmware-amd-graphics

I've attached my sources.list as a pattern, though you can leave out
the lines starting with deb-src.

Cheers,
David.

Thanks for the reply. I have finally solved this problem. First, if I let the OS load normally, I get the video error message and the system  locks up. If I use rescue mode there is no network access. Catch 22.

The actual problem was that I was missing the proper firmware for my Radeon video card. I finally found this by running "journalctl -xb" which lists all of the steps in the boot process. The error showed up in bright red on my system. Since the firmware is non-free and the normal net-install disk doesn't add contrib and non-free to the sources.list, I was stuck until I found the debian-live disks. I used the debian-live-10.40-amd64-xxx-+non-free disk. When the first choice screen pops up do not select the debian-live choice but the normal debian installation. This disk adds contrib and non-free to the sources.list. Booting this up allowed me to download the firmware I needed. Problem solved.

Gary R


Reply to: