[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [solved?] Can't Upgrade to Buster



On 7/7/19 8:19 AM, Brad Rogers wrote:
On Sun, 7 Jul 2019 07:30:51 -0500
Mark Allums <mark@allums.email> wrote:

Hello Mark,

enabling bullseye in sources.list and running apt update seems to have

Why add bullseye (testing)?  Your talk thus far has been about buster
(stable).

It seems to me that you have mixed repos in your sources.list.


I was running buster (testing) before release. Synaptic seemed to want testing. It seemed intuitive to give it what it wanted.

I don't intend to run testing for a while. I will soon comment out the bullseye line in sources.list and see what happens. But FYI, it is OK to have both stable and testing enabled when using exclusively using Synaptic. As long as you don't install massive amounts of packages from both. And as long as you don't use apt-get/apt or aptitude CLI. You can tell Synaptic to prefer whichever repository you want. By default, it prefers "highest". But you can tell it it "stable" or "testing", and it will abide by your choice.

In a few months, I will reenable bullseye and move to it.

I am not exactly sure why you are concerned about "mixed repos".

Mark


Reply to: