[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Installing Java 8 on a Google Compute Debian (Jessie) instance

I'm endeavoring to get Java 8 onto our development instance, so that the Tomcat environment there matches that of our cluster nodes, and apg-get is not cooperating.

This particular instance is a Bitnami SVN/Trac server, with Tomcat 8 added to it, and running independently of the Apache server that came with SVN and Trac.

I tried what was given at
and it didn't work. Even after doing the recommended
sudo apt-get install dirmngr
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
sudo apt-get update
sudo apt-get install openjdk-8-jdk -y --allow-unauthenticated

I still get
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openjdk-8-jdk : Depends: openjdk-8-jre (= 8u171-b11-1~bpo8+1) but it is not going to be installed
                 Depends: openjdk-8-jdk-headless (= 8u171-b11-1~bpo8+1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

which is what I was getting before.

James H. H. Lampert

Reply to: