[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: all files moved to lost+found

Hello guys,

Just an update.

I was lead to believe that a problem with the UUID in the file:

$ cat /etc/initramfs-tools/conf.d/resume    

caused the error.

For some reason, this UUID was not reflecting the real UUID of the swap file.

I was about to mark this as "solved" by that. But for my surprise, look at this events (reported as an image here in imagebin, sorry about that):


After gcc fatal error saying the file (that is open in another terminal, with vim, which I just compiled a few lines above successfully,) didn't exist, I went to the other terminal, typed ":w" in vim, so to save it again, and back to the compile terminal it found the file.

How come!?? It is amazing. This machine is doomed, or the system, not sure. Something is really wrong here. I can lose files just like that!?

Thanks for any input.


PS. Maybe I should start a new installation from scratch, or maybe just to be sure, start using the dual boot I've installed as Devuan, which I'm still not fully using. It is just there, just in case. I don't know. Maybe it is a KDE thing, because I tried to TEST all hardware (disk and memory). 

PS. Ok, I was fast in screenshot, afraid to lose the error. But now that I wrote this email easily, here it is, the same info in the image above, as text. No need to see the image anyway.

[20181010.010115, !5088]$ gcc mequine.c -o mequine.x -Wall -Wextra -g -O0
mequine.c: In function ‘main’:
mequine.c:21:17: warning: implicit declaration of function ‘printcscc’ [-Wimplicit-function-declaration]
[20181010.010304, !5088]$ gcc mequine.c -o mequine.x -Wall -Wextra -g -O0
gcc: error: mequine.c: No such file or directory
gcc: fatal error: no input files
compilation terminated.
[20181010.010328, !5088]$ gcc mequine.c -o mequine.x -Wall -Wextra -g -O0
[20181010.010345, !5088]$ springe ~/tmp/nofileScreenshot_20181010_010612.png  

>>>> It was a simple cycle: compile, error, fix, save, compile again (AND THE FILE DISAPPEARED), save again, compile again (ALL GOOD).

On Fri, 5 Oct 2018 at 10:33, Gene Heskett <gheskett@shentel.net> wrote:
On Friday 05 October 2018 08:53:14 Beco wrote:

> Dear linux users,
> The memtest86+ came out clean.
> I run out of ideas to what was the problem.
> Wasn't it a very serious problem I would already stop writing emails.
> But to have the whole /home disappear, is something that changes your
> expectations for the whole linux experience.
> It has to have a simple explanation hidden somewhere (and
> testable/repeatable/provable, not just guesses)
> Thanks,
> Beco

In that event, I'd be checking the drive makers web site for firmware
updates for YOUR drive(s)

Seagate is pretty good about that.

I'm not saying this is your problem, but it is something to investigate.

The last 1T drive I updated had already used up 25 sectors as
re-allocated at < 5,000 spinning hours. After the update it was about
25% faster, and 80,000+ spinning hours later, still had that same 25
re-allocated sectors. Its a good drive yet but amanda needed more space,
so it got replaced with a 2T drive. Stretch isn't stable yet,way too
many networking problems so I'll probably wait till buster turns stable.
Networking already Just Works from the reports I read here.

Cheers, Gene Heskett
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
Genes Web page <http://geneslinuxbox.net:6309/gene>

Dr Beco
A.I. researcher

"I know you think you understand what you thought I said but I'm not sure you realize that what you heard is not what I meant" -- Alan Greenspan

Creation date: pgp.mit.edu ID as of 2014-11-09

Reply to: