[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

default grub config location for PXE UEFI boot

Hey guys,  I'm trying to setup isc-dhcp-server/tftpd-hpa for PXE UEFI
netboot installs.  I have a working config for bios PXE installs,  but
am trying to convert it over to allow for UEFI installs aswell.
Currently,  I can PXE boot UEFI clients,  but end up with a bare grub
prompt.   I'm just not sure where and what the default grub config
file is supposed to go.

Also,  we have a mix of bios/UEFI machines,  would I need to maintain
a separate boot config file for both bios/uefi pxe mode?  Or can I
just symlink it once I get the proper location determined?  I've found
some config snippets for the dhcp service to serve both bios and uefi
payloads at the same time,  but haven't got there yet.

My tftp root looks like so.

lrwxrwxrwx 1 root root    37 Aug 22 17:23 bootnetx64.efi ->
drwxrwxr-x 3 tftp tftp  4096 Jul 11 03:19 debian-installer
lrwxrwxrwx 1 tftp tftp    47 Jul 11 03:19 ldlinux.c32 ->
-rw-r--r-- 1 tftp tftp 26664 Jul 27 19:37 memdisk
lrwxrwxrwx 1 tftp tftp    33 Jul 11 03:19 pxelinux.0 ->
lrwxrwxrwx 1 tftp tftp    35 Jul 11 03:19 pxelinux.cfg ->
-rw-r--r-- 1 tftp tftp 21198 Aug  7 16:21 stretch-pxe.cfg
-rw-rw-r-- 1 tftp tftp    62 Jul 11 03:19 version.info

Some googling led me to believe the config file for UEFI pxe booting
is called efidefault.  I've tried dropping that config in several
directories without much luck.  Tried turning verbosity up in tftpd-ha
to determine what file is trying to be pulled,   but the tftp logs
only show a transfer of bootnetx64.efi and no other attempts at a
config file.

Thanks for the help.

Reply to: