[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: painted into a corner



On Mon, Aug 20, 2018 at 04:42:00PM -0400, Gene Heskett wrote:
> On Monday 20 August 2018 13:53:14 Brian wrote:
> > On Sun 19 Aug 2018 at 20:58:28 -0400, Gene Heskett wrote:
> > > On Sunday 19 August 2018 17:33:32 David Wright wrote:
> > > > Can you not run your stretch installation then? In a new system,
> > > > I'd mount the old wheezy disk(s) and pull the files across.
> > > > Leaving the wheezy mount there makes it easy to look back at the
> > > > old system in case you forget a file or just want to see how you
> > > > used to do a particular something.
> > >
> > > That is what I'll likely do when I next boot to it, but the tools to
> > > make that easy are often in the missing list. I did get synaptic to
> > > install mc, but had all sorts of perms problems I didn't expect when
> > > I tried to use it, due I think to the changes in what says is ext4
> > > on both disks. We will eventually get it sorted I hope.  So I'll be,
> > > without a doubt, back with more problems but hopefully making
> > > progress over the next week or so. Progress always puts me in a
> > > better mood than I was for the first post in this thread.
> >
> > My suggestion is along the same lines as David Wright's.
> >
> > Boot the installer and stop when you get to partitioning.
> > Switch to a console (ALT-F2) and mount the wheezy and stretch
> > partitions. Use cp to copy files between the two partitions.
> 
> If push comes to shove, I'll see if a wheezy disk can be mounted to a 
> stretch mount point.

That's what I'd do - just boot stretch and mount your wheezy
partition(s).  Newer OSes are designed in general to be backwards
compatible - people scream at the sky when a previous disk cannot be
mounted.


> Someplace in the last 2 days ISTR trying that after 
> booting stretch, and mount worked but navigating in the disk failed,

That was probably "navigating to my old /home/ folder" perhaps?

You need to mount your original partition for /home I suspect, not
just the root partition, that's all...


> the root was all I could see, and when I rebooted to wheezy, I had
> a 15+ minute pause while it did an e2fsck to most of that 1
> terabyte disk, without reporting any errors found that it told me
> about on the boot screen. That would spook most anybody I think.

It's possible you shut down too quickly?  Or could the drive have
been disconnected before unmounting the old wheezy /root ?


> But now, for no known reason, stretch's network has gone away.  And all 
> the tools I am familiar with have been excised from stretch.  Sigh...

Hm, frustrating.

Networking should work roughly the same in both wheezy and stretch.

If you want it auto shiny, just apt install network-manager

Good luck,


Reply to: