[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yabasic problem

On 08/19/2018 08:50 AM, Richard Owlett wrote:
On 08/19/2018 08:36 AM, tomas@tuxteam.de wrote:

   - try running your program under strace: there you'll see which
     system calls are being issued, and perhaps gain some insight
     on where this "No such file..." (ENOENT) really happens and
     what argument values are being passed to the system call.

     (as a very short intro:

       strace -o <my/trace/file/name> yabasic
       [do your thing]
       [go carefully with a pitchfork through your trace file
        looking out for your file names and for ENOENT]

     Holler here if you need help with strace. It's a handy tool
     in any hacker's toolbox.

Didn't know of strace. Just glanced at manpage. On my way out - pursue this afternoon.

MIXED results.

In the yabasic mode I was using {enter basic program and hit Enter twice to execute}, strace and yabasic do not "play well together". The basic program is never executed.

However if you do:
      > strace -o mytrace yabasic test.bas
it executes, but doesn't apparently doesn't give any explanation ow why the two files cannot be opened.

*HOWEVER* perhaps my system and strace do not "play well together".
A tutorial I found gave as a first example: > strace -o mytrace yabasic ls
That gave 10 {apparently spurious} file errors before running "ls" normally.

I then tried some brute force trouble shooting and discovered that the problem was specifying a complete path to target files. I moved them to my home directory and all worked fine.

Now to solve logic flaws in my code ;/
Thank you.

Reply to: