[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: netboot images for Debian 9 seems is broken?

On Fri, Jun 15, 2018 at 01:43:50AM +0000, Andy Smith wrote:
> Hi,
> On Thu, Jun 14, 2018 at 03:29:28PM -0400, mizuki wrote:
> > "No kernel modules were found. This probably is due to a mismatch between
> > the kernel used by this version of the installer and the kernel version in
> > the archive.
> In my experience, the above is correct. That is, I've experienced
> this sort of thing 3 or 4 times and every time that has been the
> reason for it.

Forgive me if this is a stupid question but what exactly does that mean
ie what is "the archive"?  Presumably that means a mismatch between the
linux kernel and the kernel modules in the initrd or am I very much

> > If you're installing from a mirror, you can work around this problem by
> > choosing to install a different version of Ubuntu. The install will
> > probably fail to work if you continue without kernel modules"
> It's a bit odd that it says Ubuntu when you used a Debian netboot.

I've never seen it mention Ubuntu but I think I saw the same error
described when I added Debian 9 to my PXE server.  I think I managed to
find a different kernel and initrd so I tried that too which got a
little further but as far as I can tell, didn't have the ext drivers, so
couldn't mkfs when it got the file system creation part of the install
process.  I have to confess, I didn't get any further, as a work-around,
I found something else to occupy my time.

> Use daily netboot image, pick a different mirror?

Thanks for this tip.  I didn't know such a thing existed.  I'll have a
try to remember to have a got at fixing this when I get home, as it's
rekindled my interest in getting it working.

Are the PXE installers known to be a little flaky?  I've found them a
little hit and miss in the past but never put enough effort into working
out if it was me or someone else that was at fault :-)


Attachment: signature.asc
Description: PGP signature

Reply to: