[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mkisofs (was: Installer image for installation via ssh)

On 4/19/18, tomas@tuxteam.de <tomas@tuxteam.de> wrote:
> Hash: SHA1
> On Thu, Apr 19, 2018 at 04:42:30PM +0200, Leandro Noferini wrote:
> [...]
>> I tried this solution but I had to stop at last passage, when we need to
>> recreate the new image. In the article there is this command
>> mkisofs -o ../custom_install.iso -r -J -no-emul-boot -boot-load-size 4
>> -boot-info-table -b isolinux/isolinux.bin -c isolinux/boot.cat ../isonew
>> But mkisofs does not exist in debian anymore. In its place (?) we have
>> genisoimage but I cannot find the right options to have the same result.
>> What do I need to give as options?
> Hm. Going by what the Internet says [1], [2] (I know, I know),
> genisoimage should be command-line compatible with mkisofs.
> Cheers
> [1]
> https://askubuntu.com/questions/557910/difference-between-mkisofs-and-genisoimage
> [2]
> https://www.linuxquestions.org/questions/linux-software-2/what-should-we-use-to-make-iso-images-mkisofs-or-genisoimage-674086/

The only reason I knew anything about "xorriso -as mkisofs" is because
something related to both genisoimage and mkisofs wasn't working for
me, either. This Debian Wiki page is part of what I remember visiting
last year:


My memory this second is that the chatter went beyond just that
genisoimage was not being maintained, but I don't remember exactly
what convinced me to install yet another package (xorriso). Maybe it
was that mention about licensing combined with the possibility of a(n
alleged) stalled maintenance program. :)

One question I'm left with now is that I'm getting zero response for
"apt-cache search xorrisofs". I must have hit up the Internet yet
again to find xorriso as an option. That or I chipped the "fs" off the
tailend and tried "apt-cache search xorriso" instead... ? :)

Cindy :)
Cindy-Sue Causey
Talking Rock, Pickens County, Georgia, USA

* runs with duct tape *

Reply to: