[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Debian-Stretch on macmini-4.1] Can't get X working with nvidia

* Henning Follmann <hfollmann@itcfollmann.com> [120318, 08:09]:
> On Sat, Mar 10, 2018 at 12:21:17AM +0100, Ennio-Sr wrote:
> > Hi all!
> > [...]

> > ...solution to the 'black screen' coming out running startx, I'm curious to
> > know if there is any of you with the same hardware who found a
> > workaround and would share it.
> I do have a macbookpro and for me it was exactly the issue. e.g. The
> graphics adapter by default is not bus master.
Sorry, I do not understand what #'is not bus master'# means

> > 
> > Looking at the various logs I can't find any clue. 
> > Reading <https://wiki.debian.org/NvidiaGraphicsDrivers#configure> I also
> > consulted the suggested link 'http://askubuntu.com/a/613573/134848' but
> > as its author worked on a MacBook7,1 whereas mine is macmini4,1 I'm
> > afraid either I misunderstood his advices concerning the 'setpci -s' (my
> > values where different) or that patch is not applicable to macmini.
> > 
> what is the result of 
> nvidia-detect
> ?
I can't tell because in the meantime I went back to the 'nouveau'
driver: up to now it hasn't yet frozen (cross fingers ;-)
However, Xorg.?.log showed the module was detected and loaded and this
fact is asserted by the following lines extracted from a 'journalctl -xb
--boot=-x' (where 'x' was the number of boot when nvidia was installed)

> what does 
> sudo lshw -businfo -class bridge -class display
> report back?

Ok, this is the result with nouveau installed, but it was identical when
nvidia was installed (of course, being hw stuff)

Bus info          Device      Class          Description
pci@0000:00:00.0              bridge         MCP89 HOST Bridge
pci@0000:00:03.0              bridge         MCP89 LPC Bridge
pci@0000:00:0e.0              bridge         NVIDIA Corporation
pci@0000:01:00.0              bridge         XIO2213A/B/XIO2221 PCI Express to PCI Bridge [Cheetah Express]
pci@0000:00:15.0              bridge         NVIDIA Corporation
pci@0000:00:16.0              bridge         NVIDIA Corporation
pci@0000:00:17.0    <->       bridge         MCP89 PCI Express Bridge
pci@0000:05:00.0    <->       display        MCP89 [GeForce 320M]

> and the file you created
> /etc/grub.d/01_enable_vga.conf

> can you pleas list the contents of this file?

Here it is (I saved it before removng nvidia):

# 01_enable_vga.conf
# per modificare i valori del bridge e del display della nvidia
# cfr. proprietary-nvidia-drivers-on-mac-with-efi (ask ubuntu)
  setpci -s "00:17.0"  3e.b=8
  setpci -s "05:00.0"  04.b=7

Note that when I checked, as suggested by the ubuntu link author, with
  $ sudo setpci -s "00:17.0" 3e.b
  $ sudo setpci -s "05:00.0" 04.b
I obtained the correct values.

Some further considrations:
While I'm writing this answer I'm recalling to my mind that I was acting
in complete ignorance of what all that mean, particularly the 3e.b=8
etc. In the meantime I have desperately searched the web for an
explanation of hex structure, which I found a few hours ago. And the
only doubt, now, is that I might have first given that setpci
instruction with the same values of ubuntu post (05.b=7) and after
getting the black screen having corrected to 04.b=7.
I am still not sure which value would have been correct and if you know
please tell me just for the case I might go back again to nvidia in case
of new frequent frozes of nouveau.

Many thanks for your help. Regards, Ennio

[Perche' usare Win$ozz (dico io) se ..."anche uno sciocco sa farlo.   \\?//
 Fa' qualche cosa di cui non sei capace!"  (diceva Henry Miller) ]    (°|°)
[Why use Win$ozz (I say) if ... "even a fool can do that.              )=(
 Do something you aren't good at!" (as Henry Miller used to say) ]

Reply to: