[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Need Help restoring a filesystem on an external drive WD 'My Book'

Hi to Everyone,


WD P/N : WD10000H 1Q

S/N : WCAU4D 164675

is about 4 or 5 years old. It is an external drive using external power supply. At start, I had formatted it in ext3, so that I 'd be able to storage videofiles larger than 2 Gb. Since then, I storaged a number of files in several directories, subdirectories etc.. I never had any problem until now.

This drive no longer mounts. It does not mount automatically as it used to, and I don't know how to mount it manually. My other similar drives mount on /dev/sdb1 or /dev/sr0... depending on to which computer I mount it. In case it doesn't automatically mount, I just type :

#mount /dev/sdb1 /media/bd/ext

and it works

but right now I don't know for sure the device name to mount.

If I list my /dev directory using ls -lt, I can see what new device appears in the list whenever I plug my external drive. It shows 'sdb'. Not 'sdb1' as for other external drives, just 'sdb'. If now I type :

# mount /dev/sdb /media/bd/ext

this gets the external drive to react : the light goes up and down for awhile, and then I get this message :

'you must specify the filesystem'

But, if I try :

# mount -t ext3 /dev/sdb /media/bd/ext

I get this : 'wrong fs type, bad option, bad superblock on /dev/sdb…'

same result if I try mounting on 'fat', 'msdos'… filesystems, but I doubt if there are any FAT or msdos space left on this device since I had reformated it to ext3.

At last, I tried :

# fsck /dev/sdb (the external drive starts to light, then :

'fsck ext2 : superblock invalid. Trying to backup blocks

fsck ext2 : bad magic number in superblock while trying to open /dev/sdb

Now, if I type :

cat /proc/scsi/scsi

I get this :



scsi5 WD My Book Direct Access


does not show any sdb device

How am I to get this drive back to operation, or, at least, to recuperate the datafiles that are stored in that WD external drive ?

Thanks in advance to tell me what diagnosis and repair tools I could use


Reply to: