[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: cups config for Brother HL-L2340DW

On 11/22/2017 01:52 PM, Pierre Frenkiel wrote:
> hi,
> For the first time in my life, I was unable to configure a printer for
> Linux,

Which GNU/Linux? Debian? If so, you should specify whether
you're using a release or testing or unstable. It could make a
difference, particularly with respect to the drivers available
in CUPS.

> Before trying to replace it, I'm curious to know whether
> somebody could make it(or a similar model) to work.
> I had no problem with the wifi config. and no problem also when printing
> from Windows, but no way with CUPS.  Of course, I looked at Google,
> and tried several protocols, but none worked. 
> Has anybody an idea?

Since you didn't say exactly what you tried, it's hard to know
what to suggest.

I'm sure most people just download and install the drivers that
Brother supplies on their support site. However, those are a
real mess, IMO. But they do work.

Let me suggest an alternate strategy if you wish to avoid using
the Brother drivers. I have a Brother MFC-9340CDW. It, like your
HL-L2340DW, is not listed in CUPS. I just use the CUPS driver
for the MFC-9320CW. Works like a charm, but for the printing
functions only. I use a Brother applet on my Android phone for
handling scanning. This allows me to use the printer and the
scanner without installing the driver package from Brother.

I notice there's a driver for the HL-L2320D or similar listed in
CUPS and in the system-config-printer utility. You could try
setting that as the driver for your printer. Can't hurt to try.

BTW, I'm using Debian testing. If you're using one of the named
releases, then CUPS may have fewer driver choices available for
you to try. Just try the driver whose supported model number
comes closest to your printer's model number.

My printer is actually supposed to be driverless, but Brother
screwed up (apparently) on its firmware so that it reports the
wrong resolution when queried by the system. This functionality
has to be disabled on my printer in order for me to be able to
use an alternate driver without having the printer show up twice
in CUPS or systems-config-printer.

If none of this applies to your situation, you'll probably need
to provide a great deal more information about things like which
OS (exactly) and desktop environment you are using. Also, you
should specify whether you are connecting to the printer
directly or via a router. I'm assuming it's a wireless
connection of one type or the other, since you mentioned
wireless configuration.

> best regards,

Good luck!

Reply to: