[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X crashes in stretch (hint: kernel)

It must be something in the kernel, because, as I still have 3.16.0-4-amd64,
now I booted with that and I'm writing using TB on X, which means X is working.
 The bad kernel is linux-image-4.9.0-3-amd64, I'm not going to boot it any
more, except possibly for testing.

I'm somewhat surprised, because the bad kernel issued messages like so:

[Sep10 12:37] gnome-shell[24752]: segfault at 7fc9aceb7c90 ip 00007fc9aceb7c90
sp 00007ffcc219b688 error 15 in gschemas.compiled[7fc9ace7b000+4a000]
[  +1.362249] gnome-shell[25122]: segfault at 7f1e99047c90 ip 00007f1e99047c90
sp 00007ffc60626a78 error 15 in gschemas.compiled[7f1e9900b000+4a000]
[  +0.029115] gnome-session-f[25142]: segfault at 0 ip 00007f4fa8515e19 sp
00007ffecceb5700 error 4 in libgtk-3.so.0.2200.11[7f4fa8233000+700000]

They seem to be all flagged "user-mode" (bit 2), so the applications are
executing different code depending on the kernel version?  Or does the bad
kernel return null pointers in places where the old kernel returned valid
stuff?  (BTW, now I've been using X for a couple of hours, and didn't see any
kernel messages since.)


On Sun 10/Sep/2017 13:26:43 +0200 Alessandro Vesely wrote:
> Hi,
> after upgrading to sretch, no graphics work anymore.  The upgrade brought in
> systemd-sysv instead of sysvinit-core, which I had in jessie.  I don't know
> which other packages, if any, went that route...
> Gdm3 wasn't even able to display anything readable.  It worked well in jessie. 
> In stretch, its screen was fubar as if an img with the wrong
> width was splashed to the graphic memory.  Changing to lightdm looks
> better.  However, X crashes after logging in.
> I tried reinstalling and reconfiguring a number of packages, to no avail.
> I logged in on the tty and issued startx twice.  The first time I tried to open
> a terminal:  a terminal window opened momentarily, the background disappeared,
> and then I was back to text mode.  The second time I opened gnome-chess, played
> a few moves and closed the chess window.  Dmesg reported:
> [Sep10 12:49] gnome-shell[25411]: segfault at 88feb010 ip 00007f519a31fca3 sp
> 00007ffd7d23bb80 error 4
> However, X didn't crash.  I reopened gnome-chess and closed, and this time
> crashed.  I don't attach X logs, as they are longish.  I coped them here:
> http://www.tana.it/Xorg.xterm.log
> http://www.tana.it/Xorg.gnome-chess.log
> The few dmesg lines relative to each session are appended at the bottom of each
> log.
> Can someone please help me fix this pc, anyhow?  I have no idea how to
> proceed.  Even reassuring that working settings exist will help.
> Thank you
> Ale

Reply to: