[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X crashes in stretch

after upgrading to sretch, no graphics work anymore. The upgrade brought in systemd-sysv instead of sysvinit-core, which I had in jessie. I don't know which other packages, if any, went that route...

Gdm3 wasn't even able to display anything readable. It worked well in jessie. In stretch, its screen was fubar as if an img with the wrong
width was splashed to the graphic memory.  Changing to lightdm looks
better.  However, X crashes after logging in.

I tried reinstalling and reconfiguring a number of packages, to no avail.

I logged in on the tty and issued startx twice. The first time I tried to open a terminal: a terminal window opened momentarily, the background disappeared, and then I was back to text mode. The second time I opened gnome-chess, played a few moves and closed the chess window. Dmesg reported:

[Sep10 12:49] gnome-shell[25411]: segfault at 88feb010 ip 00007f519a31fca3 sp 00007ffd7d23bb80 error 4

However, X didn't crash. I reopened gnome-chess and closed, and this time crashed. I don't attach X logs, as they are longish. I coped them here:
The few dmesg lines relative to each session are appended at the bottom of each log.

Can someone please help me fix this pc, anyhow? I have no idea how to proceed. Even reassuring that working settings exist will help.

Thank you

Reply to: