[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: hibernate uses a wrong UUID

You should not use "uswsusp" anymore on recent OS releases. Hibernate
should work "out-of-the-box" assuming swap partition is big enough.
Remove "uswsusp", double check "/etc/fstab" swap entry

    $ sudo blkid | grep swap
    /dev/sdb2: LABEL="swap" UUID="d0331ef1-bc12-473f-bd4a-b4edf0d4d0a8"
TYPE="swap" PARTUUID="88839920-fc62-4f3a-aa7c-e97cd1ed4d5d"

    $ cat /etc/fstab | grep swap
    UUID=d0331ef1-bc12-473f-bd4a-b4edf0d4d0a8    none    swap    sw   
0    0

and "/etc/initramfs-tools/conf.d/resume"

    $ cat /etc/initramfs-tools/conf.d/resume

Check swap is working via "swapon"
After that either reinstall initramfs-tools via

    $ sudo apt-get install --reinstall initramfs-tools

or update initramfs via
    $ sudo update-initramfs -u -v | grep "Adding config"

This way you can see all config files and check them if swap
partition\hibernation image is still not found.
Reboot and try to hibernate.

On 10.09.2017 16:13, Pierre Frenkiel wrote:
> On Sat, 9 Sep 2017, Cindy-Sue Causey wrote:
>> Pierre's bug, he shared that extra bit about how it's checking for a
>> wrong UUID. It's possible I'm not cognitively grasping that the same
>> is mentioned in Bug #861057, but right now I'm not seeing that
>> referenced there. Maybe that was what was going on under the hood on
>> that closed bug, too..........
>   I recently increased my swap partition size, and the wrong UUID
>   was that of the old swap, and was set in the resume option of grub.cfg.
>   After updating grub, this problem disappears, but anyway, the
> hibernate stuff in Debian
>   seems really crazy:
>   I found 3 different places where the resume can be defined
>       /etc/uswsusp.conf
>       /boot/grub.cfg
>       /etc/initramfs-tools/conf.d/resume
>   I tried all 3 together, with the following result
> Sep 10 12:20:08 pfr3 kernel: [    1.186027] PM: Checking hibernation
> image partition /dev/disk/by-uuid/42b1dc3e-6206-4bd5-9eb4-76e97f94cd65
> Sep 10 12:20:08 pfr3 kernel: [    1.201123] PM: Hibernation image not
> present or could not be loaded.
> Sep 10 12:20:08 pfr3 kernel: [    2.728912] PM: Hibernation image
> partition 8:4 present
> Sep 10 12:20:08 pfr3 kernel: [    2.728914] PM: Looking for
> hibernation image.
> Sep 10 12:20:08 pfr3 kernel: [    2.729062] PM: Image not found (code
> -22)
> Sep 10 12:20:08 pfr3 kernel: [    2.729064] PM: Hibernation image not
> present or could not be loaded.
> who can explain that?
> It seems that the image was not written on disk when issuing the
> hibernate-disk command, but why ?
> best regards,

Reply to: